Issue 54580 - Fill Down in Autofilter Mode in Calc not like MS Excel
Summary: Fill Down in Autofilter Mode in Calc not like MS Excel
Status: CLOSED DUPLICATE of issue 2977
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOO 2.0 Beta2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-14 04:13 UTC by kheekien
Modified: 2005-09-14 06:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kheekien 2005-09-14 04:13:51 UTC
When a spreadsheet is filtered (Data->Filter->Autofilter), lets say that there
are 3 columns, with headers named as "Bug Description(BU)", "Severity (S)" and
"Assigned To (A)", and you have the following rows:

BU               S         A
==============   ======    =======
Bug Desc 1       Moderate  
Bug Desc 2       Moderate  
Bug Desc 3       Moderate  
Bug Desc 4       Moderate  
Bug Desc 5       Minor     
Bug Desc 6       Minor     
Bug Desc 7       Minor     
Bug Desc 8       Moderate  
Bug Desc 9       Moderate  

When I filter the list by Severity, by moderate, naturally I will get

BU               S         A
==============   ======    =======
Bug Desc 1       Moderate  
Bug Desc 2       Moderate  
Bug Desc 3       Moderate  
Bug Desc 4       Moderate  
Bug Desc 8       Moderate  
Bug Desc 9       Moderate  

Say, when I try to assigned the issue to Peter for example, go to the cell
marked "X" and try to fill down "Peter" to the rest of the rows for moderate as
in the following example:

BU               S         A
==============   ======    =======
Bug Desc 1       Moderate  Peter
Bug Desc 2       Moderate  
Bug Desc 3       Moderate  
Bug Desc 4       Moderate  
Bug Desc 8       Moderate  
Bug Desc 9       Moderate  X

I get this:

BU               S         A
==============   ======    =======
Bug Desc 1       Moderate  Peter
Bug Desc 2       Moderate  Peter
Bug Desc 3       Moderate  Peter
Bug Desc 4       Moderate  Peter
Bug Desc 8       Moderate  Peter
Bug Desc 9       Moderate  Peter

which seems to be correct. But on removing the filter I get the following:

(Behaviour A)
BU               S         A
==============   ======    =======
Bug Desc 1       Moderate  Peter
Bug Desc 2       Moderate  Peter
Bug Desc 3       Moderate  Peter
Bug Desc 4       Moderate  Peter
Bug Desc 5       Minor     Peter
Bug Desc 6       Minor     Peter
Bug Desc 7       Minor     Peter
Bug Desc 8       Moderate  Peter
Bug Desc 9       Moderate  Peter

instead of this:

(Behaviour B)
BU               S         A
==============   ======    =======
Bug Desc 1       Moderate  Peter
Bug Desc 2       Moderate  Peter
Bug Desc 3       Moderate  Peter
Bug Desc 4       Moderate  Peter
Bug Desc 5       Minor     
Bug Desc 6       Minor     
Bug Desc 7       Minor     
Bug Desc 8       Moderate  Peter
Bug Desc 9       Moderate  Peter

which should be the correct behaviour.
Comment 1 Rainer Bielefeld 2005-09-14 06:23:43 UTC
DUP!

@ kheekien
Thanks for your report, developers are just working on this problem. Pls. read
Additional comments from oc Thu Jul 14 03:08:00 -0700 2005 in issue 2977!

*** This issue has been marked as a duplicate of 2977 ***
Comment 2 Rainer Bielefeld 2005-09-14 06:24:23 UTC
.