Issue 54703 - Easter Egg in Calc
Summary: Easter Egg in Calc
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOO 2.0 Beta2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
: 65352 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-09-16 14:17 UTC by davide
Modified: 2006-05-14 16:06 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description davide 2005-09-16 14:17:50 UTC
1. create a new sheetin openoffice.org Calc (spreadsheet)
2. enter this formula in a cell :
=game()
and validate (validation button or enter)
3.the cell will display "say what?"
4. Enter this formula:
=GAME("StarWars")
5. a new window will open with a little game star war game.
6. But if you type again this formula, the cell will return the display "oh no,
not again!"
7. to be able to play again, you need to close the file, close openoffice.org
and the QuickStarter, and then make the same.

What does it means?
Comment 1 pavel 2005-09-16 16:32:29 UTC
This is not issue.

Closing.
Comment 2 pavel 2005-09-16 16:32:54 UTC
closing.
Comment 3 davide 2005-09-16 19:32:26 UTC
It's real. This is an Easter Egg and I'd like to know why.
I want a know why there is a game in an office automation suite. And the worst
not documented. 

If there is such Easter Egg, what about other malicios code? How people can
trust on OOo?

Davide
 
Comment 4 flibby05 2005-09-17 08:19:01 UTC
hello ddozza,

>>I want a know why there is a game in an office automation suite.

thats the sense of an easteregg.

> And the worst not documented. 

see above ;-)

>>If there is such Easter Egg, what about other malicios code? How people can
>>trust on OOo?

There is no malicious code in ooo. ooo is opensource, people can and do check
the code for bugs and all types of potentially harmful code.

Besides all of that ooo has a strict policy concerning new code submissions.
This makes it very difficult to succeed in getting malicious code submitted to
the sources.

Regards, Max

-> closed.
Comment 5 flibby05 2005-09-17 08:19:20 UTC
.
Comment 6 pavel 2006-02-06 14:02:22 UTC
*** Issue 61667 has been marked as a duplicate of this issue. ***
Comment 7 frank 2006-05-14 16:06:55 UTC
*** Issue 65352 has been marked as a duplicate of this issue. ***