Issue 54710 - slide advance ...
Summary: slide advance ...
Status: CLOSED DUPLICATE of issue 54381
Alias: None
Product: Draw
Classification: Application
Component: ui (show other issues)
Version: 680m125
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.0
Assignee: clippka
QA Contact: issues@graphics
URL: http://specs.openoffice.org/impress/s...
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-16 17:27 UTC by mmeeks
Modified: 2006-07-24 16:42 UTC (History)
2 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mmeeks 2005-09-16 17:27:20 UTC
So, I was knobbled by a lovely chap from HP at Brainshare about this. It turns
out that a load of hand-held slide flipping consoles actually emulate the 'right
cursor key' effect instead of left;right click for slide next/previous effect.

Unfortunately in OO.o 2.0 this flips to the next slide without advancing through
any of the effects (which is a pain). Of course - we have no 'previousEffect'
method in the IDL/impl. (which I spent 10 minutes trying to unwind without great
success - too many asynchronous events & not enough understanding of them ;-)

So - this fixes only the right arrow key - at least some way to fixing it fully:

--- sd/source/ui/slideshow/slideshowimpl.cxx
+++ sd/source/ui/slideshow/slideshowimpl.cxx
@@ -1834,6 +1834,7 @@
 
 			// advance show
 			case KEY_SPACE:
+			case KEY_RIGHT:
 				mxShow->nextEffect();
 				update();
 				break;
@@ -1873,7 +1874,6 @@
 				break;
 
 			case KEY_PAGEDOWN:
-			case KEY_RIGHT:
 			case KEY_DOWN:
 			case KEY_N:
 				gotoNextSlide();

HTH.
Comment 1 wolframgarten 2005-09-19 07:49:57 UTC
Reassigned, please handle.
Comment 2 groucho266 2005-09-19 09:00:33 UTC
I do not think that changing the behaviour for RIGHT but not for LEFT is such a
good idea.

->DBO: I think that you are currently working on a related topic.  Please have a
look.
Comment 3 thb 2005-10-07 14:05:05 UTC
@mmeeks: that we cannot currently wind back single effects (compared to full
slides) is a bug - issue 48179. Generally, we behave somewhat differently from
PPT (which does 'next effect' on everything from space to cursor right/down and
page down, as well as 'prev effect' on cursor left/up and page up). Thus the
obvious probs with those Windoze-targeted gadgetry.

@dbo, @cl: shouldn't we change the cursor right/left behaviour ASAP (read: for
2.0.1 or 2.0.2) - those slideshow remote controls won't probably adapt to OOo
anytime soon...
Comment 4 Daniel Boelzle [:dbo] 2005-11-22 17:17:30 UTC
depends on issues 48179 and 45197
Comment 5 Daniel Boelzle [:dbo] 2005-11-25 15:03:39 UTC
@THB: as agreed to you...
Comment 6 thb 2005-12-29 13:55:31 UTC
This doesn't really depend on neither issue 48179 nor issue 45197 - those will
only make the experience more smoothly. 

@cl: shouldn't we change the cursor left/right behaviour ASAP? Anything that
needs to be spec-ed/any spec to be changed?
Comment 7 thb 2006-01-02 15:10:10 UTC
@cl: as requested.
Comment 8 clippka 2006-01-04 10:42:05 UTC
I will add this patch but since we already have an earlier issue describing this
problem I will set this one to duplicate. Spec and fix will be done with issue 54381

*** This issue has been marked as a duplicate of 54381 ***
Comment 9 clippka 2006-01-04 10:43:04 UTC
closing
Comment 10 mmeeks 2006-01-05 10:56:37 UTC
You're sure that these are the same issue - i#54381# on the face of it talks
about page-up rather than the left/right arrow keys.
Comment 11 matthias.mueller-prove 2006-02-27 14:56:47 UTC
spec to come
Comment 12 clippka 2006-07-24 16:42:28 UTC
yes i'm sure, the spec deals with all keyboard shortcuts