Issue 54736 - Paste large html from clipboard takes "forever"
Summary: Paste large html from clipboard takes "forever"
Status: CLOSED DUPLICATE of issue 25680
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOO 2.0 Beta2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: ms_interoperability, oooqa
: 54737 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-09-17 21:12 UTC by cbn
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Data to copy to clip board, zipped (303.30 KB, application/octet-stream)
2005-09-17 21:16 UTC, cbn
no flags Details
Debug/dump info from Windows (401.27 KB, text/xml)
2005-09-17 21:18 UTC, cbn
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cbn 2005-09-17 21:12:29 UTC
Load the attached Word document (originally from an html document pasted into 
Word). Select all and paste it into an open OO 2.0 beta writer. This 
takes "forever" ("forever" > 60 minutes).

When the process is killed via Task Manager, then Windows catches the problem 
in the error reporting. The report is attached as well.

The problem is reproduceable after restart of Windows as well as in a new OO 
process.
Comment 1 cbn 2005-09-17 21:16:58 UTC
Created attachment 29627 [details]
Data to copy to clip board, zipped
Comment 2 cbn 2005-09-17 21:18:10 UTC
Created attachment 29628 [details]
Debug/dump info from Windows
Comment 3 cbn 2005-09-17 21:20:06 UTC
If you paste the same content in to Writer/Web empty document it works fine. 
It takes a couple of seconds, but that's it.
Comment 4 cbn 2005-09-17 21:34:44 UTC
oo beta 2 => 1.9.125
Comment 5 ingenstans 2005-09-18 11:07:19 UTC
There is definitely something funny with the way this document is imported into 
OOo. It displays fine in web view; but when it comes to display in print view, 
many of the tables seem to have disappeared altogether, and those that can be 
seen bleed off the right-hand margin of the page. It looks to me like a bad 
problem with table layout in print view. 
Comment 6 ingenstans 2005-09-18 11:10:57 UTC
The tables involved seem to be too wide for the paper. They give their width as 
20.45cm, which is not going to squeeze onto US Letter paper with normal margis. 
Comment 7 michael.ruess 2005-10-05 12:31:51 UTC
Reassigned to ES.
Comment 8 eric.savary 2005-10-07 13:59:05 UTC
ES->MRU: back to you. I suppose that the tables have complex layout which kills
the breaking cell feature. Your opinion.

Else, slow pasting: I cannot reproduce it. Maybe the document contents some
Internet links which cannot be quickly resolved? Please check that you have
entered the proxy info under Tools - Options Internet.
Comment 9 michael.ruess 2005-10-13 15:33:44 UTC
The problem "pasting takes forever" is not reproducable with a anewer build like
680m132.
The problem, that the document looks wrongly when importing in 'O Writer is due
to the missing support of nested tables in Writer's import filter. See issue 25680.

*** This issue has been marked as a duplicate of 25680 ***
Comment 10 michael.ruess 2005-10-13 15:34:25 UTC
Closing duplicate.
Comment 11 eric.savary 2006-03-13 16:02:58 UTC
*** Issue 54737 has been marked as a duplicate of this issue. ***