Issue 54780 - Incorrect non-Unicode fonts mapping
Summary: Incorrect non-Unicode fonts mapping
Status: CLOSED WONT_FIX
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m128
Hardware: PC Windows Server 2003
: P2 Trivial (vote)
Target Milestone: ---
Assignee: ulf.stroehler
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-19 08:38 UTC by pmike
Modified: 2010-04-28 11:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
OO Writer cannot display Russian symbols (22.50 KB, image/png)
2005-09-19 08:41 UTC, pmike
no flags Details
MS Word displays symbols, but only with font actually have them (23.56 KB, image/png)
2005-09-19 08:42 UTC, pmike
no flags Details
AnnaCTT font for testing (have Russian symbols) (30.35 KB, application/x-compressed)
2005-09-19 08:44 UTC, pmike
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description pmike 2005-09-19 08:38:32 UTC
OO cannot display national symbols with non-Unicode fonts, even if font have
such symbols. The resulting text looks really ugly, because choosen font is
being substituted with default one. This issue affects all OO components (Write,
Calc, etc.)

MSO works different. It correctly displays chars, if non-Unicode font have them
and draw rectangles if not.
Comment 1 pmike 2005-09-19 08:41:05 UTC
Created attachment 29654 [details]
OO Writer cannot display Russian symbols
Comment 2 pmike 2005-09-19 08:42:13 UTC
Created attachment 29655 [details]
MS Word displays symbols, but only with font actually have them
Comment 3 pmike 2005-09-19 08:44:06 UTC
Created attachment 29656 [details]
AnnaCTT font for testing (have Russian symbols)
Comment 4 mci 2005-09-19 17:40:09 UTC
Hi pmike,

thanks for using OpenOffice.org...

MCI -> TM:
Hi TM, is this something for US?
Comment 5 thorsten.martens 2005-09-20 08:39:33 UTC
TM->US: Please have a look, thanks !
Comment 6 ulf.stroehler 2005-09-21 16:40:05 UTC
In general none-UNICODE fonts are unsupported. If it partly works for ASCII
characters you are lucky. If it doesn't work you are alone.

The substitution font used for cyrillic glyphs when the original font doesn't
provide these glyphs (Bitstream Vera) is a sophisticated FEATURE of OO.o. Not
displaying anything as ms winword does in the provided screenshot is inacceptable.
Comment 7 pmike 2005-09-22 07:01:40 UTC
I suppose you've closed this issue in haste.

The problem is with AnnaCTT font (which *have* Russian glyphs), not with
Bitstream. This is defect, because valid text + valid font result in wrong
visualization (both screen and printing).

BTW. This issue makes impossuble for users to use their (big) custom font
collections (where most fonts are non-Unicode).

PS. If you still prefer to close the issue, please mark in WONTFIX, because
issue is not invalid. Also, you've stated clearly: OO cannot handle non-unicode
fonts properly for the moment and there is no way to fix it.
Comment 8 ulf.stroehler 2005-09-22 10:51:31 UTC
Not in haste and I didn't closed it either. I set to 'invalid' and the tool
automatically sets the issue to 'resolved'.

> The problem is with AnnaCTT font

I very well understood this. But again non-UNICODE fonts are not supported and
never will be.

> BTW. This issue makes impossuble for users to use their (big) custom font
> collections

I'm aware of this. But these kind of legacy fonts cause more than headaches and
simply are inappropriate in the age of UNICODE. 

Legacy/non-UNICODE fonts typically map their glyphs into the range of latin
glyphs but at the correct UNICODE defined positions they are blank. Hence it's
correct that OO.o performs a GlyphFallback for these positions. 
As this issue turns against the GlyphFallback feature in the description (which
is essential for OO.o) I set to 'invalid'.

Comment 9 ulf.stroehler 2005-09-22 10:53:41 UTC
.
Comment 10 pmike 2005-09-22 11:46:19 UTC
Well, it's clear that non-Unicode fonts are deprecated.
Is there a way in OO.o to distinguish between legacy and Unicode fonts then?
Comment 11 hdu@apache.org 2006-05-22 15:09:38 UTC
> Is there a way in OO.o to distinguish between legacy and Unicode fonts then?

Not that I'm aware of. Is there a "perfect OCR algorithm" that can match the
shape of any glyph to the closest looking unicode? All OCR engines I know fail
for most decorative fonts.

To distinguish between a legacy and a unicode font one would have to run the
"perfect OCR algorithm" mentionend above and compare the resulting codepoints to
the ones actually encoded in the font.

Since a perfect OCR algorithm will not be available for quite some time are
there other ideas how to distingish legacy and unicode fonts?