Issue 54794 - line end unmovable when covered by anchor icon
Summary: line end unmovable when covered by anchor icon
Status: CLOSED DUPLICATE of issue 103143
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: 680m130
Hardware: PC Linux, all
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact: issues@graphics
Depends on:
Reported: 2005-09-19 11:21 UTC by richlv
Modified: 2009-09-10 16:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

testcase (6.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2005-09-19 11:21 UTC, richlv
no flags Details
screenhots (51.35 KB, image/jpeg)
2005-09-19 12:39 UTC, wolframgarten
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description richlv 2005-09-19 11:21:03 UTC
this applies to calc and writer, but seems closely related to drwaing stuff.

see testcase. select the line, try moving its upper end - it is covered by 
anchor icon and thus is not movable.

i can't think of a perfect solution - maybe anchor icon should become 
transparent or semitransparent in this case ?
maybe it should becoma transparent if the cursor ir hovered on it for some time 
and there are control points beneath it ?
Comment 1 richlv 2005-09-19 11:21:31 UTC
Created attachment 29662 [details]
Comment 2 wolframgarten 2005-09-19 11:34:58 UTC
This only applies to calc and writer, in draw/impress the anchor cannot be achieved.
But: when hovering over the anchor with the mouse I get a cursor with a little
rectangle when the cursor is able to move the endpoint. So for me it is possible
to move it. So do you?
Comment 3 richlv 2005-09-19 11:54:11 UTC
umm, no. hovering the cursor only gives me "move" icon that moves the anchor 
itself, there is no way to access the endpoint of the line.
tried this in different combinations in both writer & calc.

if the endpoint is completely below the anchor icon, there is no way to access 

when you get that icon with rectangle, is this immediately or is there waiting 
involved ?
does this icon pop up only when cursor is positioned exactly where endpoint 
should be below anchor icon ?

i don't think window manager could affect this, but anyway - it's kde 3.4.2

additionally i tried with generic and native widtgets, that didn't help, too
Comment 4 wolframgarten 2005-09-19 12:19:35 UTC
Yes, I get the icon immediately. It is the same cursor that you get when you are
above a normal point without an anchor, for example the other end of the line. I
checked this on linux and windows, both working.
Comment 5 richlv 2005-09-19 12:28:45 UTC
i have tried with completely new user configuration (including kde &, i 
still don't get the ability to move the endpoint.

well, i also can't move anchor in calc when anchored to cell (though i am not 
sure wether i should be able to do that - if not, there should not be an icon 
that indicates ability to move on mouseover...)
Comment 6 wolframgarten 2005-09-19 12:39:40 UTC
Created attachment 29671 [details]
Comment 7 wolframgarten 2005-09-19 12:39:50 UTC
Here is a picture of the two cursor types.
Comment 8 richlv 2005-09-19 12:50:08 UTC
well, i understand what you get, so i am puzzled why i don't get the same icon 

tried in 1.1.4, m130 - behaviour is the same. i get move icon over all anchor 

if i drag line end under anchor icon, cursor stays the same (with rectangle) 
after releasing mouse button, but is transformed to move icon if i slightly move 
it. clicking immediately after releasing the button still selects the anchor 
Comment 9 wolframgarten 2005-09-23 09:17:35 UTC
Sorry, but if this cannot be reproduced here I think we cannot do anything about
it. Maybe you have some special mousepointer settings done under linux?
Comment 10 richlv 2005-09-23 12:42:42 UTC
i don't think mousepointer settings could affect this behaviour, but anyway, i 
haven't changed anything.

i have tested this on fully upgraded 10.2 slackware box, both with my existing 
and completely new user configuration.

actually it works like this :
i don't get any other icon than "move" cursor;
if i try dragging anchor icon by holding mouse pointer over a section that does 
not cover endpoint, nothin happens.

if i position the cursor at the place where endpoint supposedly is and try 
dragging that, whole line is moved (instead of an endpoint), but dotted line 
that shows new position is not shown. after releasing the mouse button line just 
jumps to the new position.
wheni _move_ the line this way (not when i hover mouse over anchor icon) mouse 
pointer changes to the one that is used when, for example, text block is moved 
by dragndrop (when i normally move line, movement cursor is shown, when i 
normally move endpoint, cursor with square is shown).

as i have tried with blank configuration, i really have no idea what could be 
wrong. version, as xwindows manages mouse at low level ? i have 6.8.

maybe i can try some configuration changes to find out what is wrong ?
Comment 11 wolframgarten 2005-09-23 13:09:31 UTC
Hello aw, please have a look what might be wrong here. Thanks in advance.
Comment 12 wolframgarten 2005-09-23 13:10:04 UTC
Comment 13 Armin Le Grand 2005-10-25 10:02:27 UTC
AW: Well, both, the anchor and the handle, are overlay controls. If the anchor
covers the handle, there is no way to grap the handle with the mouse. I also see
no good solution here. But there is a workaround: Use the keyboard functions
(TAB / SHIFT_TAB when object is selected) to select a handle and move it using
the cursor keys.
AW: Keeping as reminder, but prio5
Comment 14 Armin Le Grand 2009-09-10 16:27:45 UTC
AW: Setting to double to #i103143# since the needed changes are identical.

*** This issue has been marked as a duplicate of 103141 ***
Comment 15 Armin Le Grand 2009-09-10 16:29:01 UTC
AW: CLosing
Comment 16 richlv 2009-09-10 16:35:05 UTC
is this really dupe of the issue about autocompletion with underscore 
characters ? just making sure, as it's hard for me to imagine how needed 
changes for both of these issues are the same ;)
Comment 17 Armin Le Grand 2009-09-10 16:43:46 UTC
AW: OOps, got the wrong ID. Thanks to richlv for seeing this. Real ID double to
is #i103144. Reopening...
Comment 18 Armin Le Grand 2009-09-10 16:45:25 UTC
AW: Okay, but now...

*** This issue has been marked as a duplicate of 103143 ***
Comment 19 Armin Le Grand 2009-09-10 16:46:30 UTC
AW: CLosing again...