Issue 55152 - Filter Selection list should be sorted alphabetically
Filter Selection list should be sorted alphabetically
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P4 trivial with 5 votes (vote)
: 4.0.0
Assigned To: hdu@apache.org
:
: 41609 70162 72936 81118 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 23:12 UTC by dinojerm
Modified: 2013-07-10 06:47 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: 3.4.1
Developer Difficulty: simple
jsc: 4.0.0_release_blocker+


Attachments
suggested patch (374 bytes, patch)
2013-07-04 11:06 UTC, hdu@apache.org
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description dinojerm 2005-09-27 23:12:41 UTC
The list of filters in the 'Filter Selection' dialog (accessible by opening a
file type not detected automatically) is not currently sorted.
It should be to make it easier to use. (and it is sorted in 1.14)
Comment 1 thorsten.martens 2005-09-28 12:36:27 UTC
TM->requirements: Please have a look.
Comment 2 lohmaier 2006-10-06 18:45:27 UTC
*** Issue 70162 has been marked as a duplicate of this issue. ***
Comment 3 michael.ruess 2007-01-02 12:13:57 UTC
*** Issue 72936 has been marked as a duplicate of this issue. ***
Comment 4 michael.ruess 2007-08-29 15:02:10 UTC
*** Issue 81118 has been marked as a duplicate of this issue. ***
Comment 5 cringer0 2007-08-30 21:09:13 UTC
I agree that sorting would make it easier to use.  Thank you.
Comment 6 cactuscomputing 2008-08-20 17:43:57 UTC
Still occurs in 3.0 beta 2 (Windows Vista). As the filter list becomes longer it
gets harder to find items.  It would also be nice to mask out irrelevant entries
via an i-tunes like 'filter' field. 
Comment 7 jenf 2008-12-08 22:30:28 UTC
See this image for what a user is confronted with when the Filter Selection window opens:

http://img.skitch.com/20081208-gf5s2igr7x4mtqd8csyf5ieq3u.jpg
Comment 8 Mathias_Bauer 2009-04-20 15:53:20 UTC
I think this issue either deserves some attention or it should be rejected. I've
not made up my mind yet but my tendency is to see the current behavior as close
to useless.

Only a few formats make some sense in this list at all and some structure is
definitely needed. Otherwise it might be better to remove that dialog completely
and just state "unknown format". 

As I wrote, we have to find that out.
Comment 9 Mathias_Bauer 2009-04-20 15:54:21 UTC
At least we can present the filters in a way as we do it in the file open dialog.
Comment 10 paddylandau 2009-10-27 16:10:16 UTC
I fully concur.

It's frustratingly time-consuming to manually search through the 154 items; and
easy to miss while searching, so potentially you could search through (say) 230
items before finding what you need.

http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=23604
Comment 11 paddylandau 2009-10-27 16:12:37 UTC
*** Issue 55152 has been confirmed by votes. ***
Comment 12 kpalagin 2010-06-07 08:16:29 UTC
*** Issue 41609 has been marked as a duplicate of this issue. ***
Comment 13 kpalagin 2010-06-07 08:18:42 UTC
This issues does not seem to be that difficult to fix. Any chance for 3.3?
Comment 14 hdu@apache.org 2013-07-04 11:06:26 UTC
Created attachment 80996 [details]
suggested patch
Comment 15 jsc 2013-07-04 13:49:52 UTC
grant showstopper flag
Comment 16 jsc 2013-07-04 13:50:16 UTC
uncritical fix is already available
Comment 17 SVN Robot 2013-07-04 14:54:29 UTC
"hdu" committed SVN revision 1499775 into trunk:
#i55152# the listbox in the filter selection dialog should be sorted
Comment 18 hdu@apache.org 2013-07-04 15:02:03 UTC
My patch is applied now for AOO 4.0. Amazing that it wasn't fixed loooong ago considering the complexity of the fix vs the number of votes, duplicates, etc..

The next step for this listbox could be to use a sort key so that the most interesting choices get to the front and almost obsolete entries to the back of the list.
Comment 19 fanyuzhen 2013-07-05 06:59:47 UTC
The latest build I get is AOO 4.0 r1496831, wait for revision 1499775 or higher for verification
Comment 20 Rob Weir 2013-07-09 17:54:39 UTC
How do you reproduce this bug?  How do you "open a file type not detected automatically"?
Comment 21 hdu@apache.org 2013-07-10 06:47:42 UTC
> How do you reproduce this bug?  How do you "open a file type not detected
> automatically"?

Try to open an unrecognized file type, e.g. the attachment 80995 [details] (an XLSX 2010 file).