Issue 55992 - bezier curves are transformed to polygons when exporting to pdf
Summary: bezier curves are transformed to polygons when exporting to pdf
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0.2
Assignee: wolframgarten
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-14 13:22 UTC by timi_openoffice
Modified: 2006-02-07 09:03 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document producing the error (7.28 KB, application/vnd.oasis.opendocument.graphics)
2005-10-14 13:24 UTC, timi_openoffice
no flags Details
the resulting pdf with the polygon (1.96 KB, application/pdf)
2005-10-14 13:24 UTC, timi_openoffice
no flags Details
a screenshot of the pdf (25.57 KB, image/png)
2005-10-14 13:26 UTC, timi_openoffice
no flags Details
Problematic document (30.50 KB, application/vnd.oasis.opendocument.graphics)
2006-02-06 14:47 UTC, jefdriesen
no flags Details
Screenshot of pdf produced with openoffice 2.0.1 (97.24 KB, image/png)
2006-02-06 14:48 UTC, jefdriesen
no flags Details
Screenshot of pdf produced with openoffice build 154 (103.30 KB, image/png)
2006-02-06 14:49 UTC, jefdriesen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description timi_openoffice 2005-10-14 13:22:48 UTC
When exporting the attached draw document as PDF, the bezier curve is
transformed in a polygon. The pdf and a screenshot from the pdf are attached.
This error I could  reproduce on Linux (SuSE 9.1) and Windows 2000.
Comment 1 timi_openoffice 2005-10-14 13:24:06 UTC
Created attachment 30430 [details]
document producing the error
Comment 2 timi_openoffice 2005-10-14 13:24:48 UTC
Created attachment 30431 [details]
the resulting pdf with the polygon
Comment 3 timi_openoffice 2005-10-14 13:26:37 UTC
Created attachment 30432 [details]
a screenshot of the pdf
Comment 4 philipp.lohmann 2005-10-14 13:52:22 UTC
pl->sj: do you have an issue for that already ?
Comment 5 philipp.lohmann 2005-10-14 13:52:47 UTC
confirm
Comment 6 sven.jacobi 2005-10-21 13:02:39 UTC
Indeed, at the moment only polylines are exported using beziers, when exporting
filled polygons we do have above mentioned problems. I will try to fix this for
OOo2.02.
Comment 7 jefdriesen 2005-12-02 09:08:31 UTC
This is probably related to bug #9122.
Comment 8 sven.jacobi 2006-01-13 13:35:03 UTC
sj: sollid fings are now saved without losing bezier information.
This issue has been fixed in cws[impress82]
Comment 9 sven.jacobi 2006-01-18 12:43:48 UTC
sj->wg: this issue is now ready to be verified in cws[impress82]

re-open issue and reassign to wg@openoffice.org
Comment 10 sven.jacobi 2006-01-18 12:43:55 UTC
reassign to wg@openoffice.org
Comment 11 sven.jacobi 2006-01-18 12:44:00 UTC
reset resolution to FIXED
Comment 12 wolframgarten 2006-01-24 10:19:57 UTC
Verified in CWS.
Comment 13 wolframgarten 2006-02-01 12:55:59 UTC
Tested in master m154. Closed.
Comment 14 jefdriesen 2006-02-06 14:47:15 UTC
Created attachment 33876 [details]
Problematic document
Comment 15 jefdriesen 2006-02-06 14:48:56 UTC
Created attachment 33877 [details]
Screenshot of pdf produced with openoffice 2.0.1
Comment 16 jefdriesen 2006-02-06 14:49:37 UTC
Created attachment 33878 [details]
Screenshot of pdf produced with openoffice build 154
Comment 17 jefdriesen 2006-02-06 14:54:03 UTC
Seems like I forgot to send my comment first...

I'm seeing some very weird results with build 154 now. I attached a document
producing the behaviour and a screenshot showing the output (one for build 154
and one for release 2.0.1 build to compare). Splitting the text part does
improve the output somewhat, but the logo remains very bad.
Comment 18 wolframgarten 2006-02-07 09:03:11 UTC
This is broken since m151. The fix for this issue was implemented for m153, so
this is a different reason. I have submitted i61723 for this problem. Thanks.