Issue 56174 - Right Click In Writer Causes Hang
Summary: Right Click In Writer Causes Hang
Status: CLOSED DUPLICATE of issue 61775
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO 2.0 Beta2
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: ulf.stroehler
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-18 03:16 UTC by bengilmo
Modified: 2010-11-10 17:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bengilmo 2005-10-18 03:16:59 UTC
I have an odd and annoying bug affecting my openoffice writer. Whenever I try
to click the right mouse button over the text area the program hangs for a few
minutes. If I leave the program for a while it comes right again, without
however, displaying the right mouse button menu. The problem is isolated to
writer; calc and all the rest work fine.

 I am using the latest version, 1.9129 under Ubuntu Breezy 5.10. It has had this
problem ever since I installed the beta version a month or so ago. The same beta
version under the previous version of the distro (hoary) never showed this problem. 

 Upgrading to the latest version (the release candidate) from the openoffice
website does not cure the problem either. 

 Does anyone have any suggestions? This is driving me nuts and effectively
renders OO2 unusable. I have tried deleting my configuration files and
uninstalling, reinstalling etc with no effect. Searching around the net shows
nothing either, it seems the problem is isolated to me.

 Any help would be greatly appreciated.
Comment 1 michael.ruess 2005-10-18 09:32:56 UTC
Reassigned to ES.
Comment 2 eric.savary 2005-10-18 11:10:16 UTC
Does this only happen in the text or also in the toolbars, edit fields?
How many language dictionaries did you install?
Which window manager are you using?
Comment 3 bengilmo 2005-10-19 04:22:17 UTC
It occurs only in the text fields. Margins, toolbars etc. all work fine.

The only dictionaries installed are US English and British English.

I am using Gnome 2.12.1
Comment 4 bengilmo 2005-10-25 14:31:14 UTC

 I have found the problem. It was related to some extra fonts that I had
installed from this site http://thelinuxbox.org/Downloads.php. I removed them
from my fonts directory and the issue went away. The fonts worked with any other
program that used the fonts in ~/.fonts, only OO writer took exception to them.

 Should this still remain as a bug?
Comment 5 eric.savary 2005-10-25 14:43:16 UTC
ES->US: please have a look.
Comment 6 ulf.stroehler 2005-10-25 15:27:14 UTC
investigating.
Comment 7 ulf.stroehler 2005-10-28 14:42:27 UTC
It doesn't hang; it just needs some time to compute the list of fonts for the
"Font" list in context menu.
downloaded those fonts (5389 fonts which are 284M in size, excluding the
msttcorefonts).
So this is rather a performance issue if not an 'INVALID'.
I'd plead for closing.
Comment 8 bengilmo 2005-10-30 23:38:31 UTC
Great. Thanks for your help. I'll just leave in the fonts I need rather than the
whole shebang.
Comment 9 ulf.stroehler 2005-11-01 13:28:32 UTC
won't fix for the reasons given before.
Comment 10 ulf.stroehler 2005-11-01 13:29:11 UTC
closing 'won't fix' issue.
Comment 11 kpalagin 2007-04-05 10:15:32 UTC
Reopening to set as dup of http://www.openoffice.org/issues/show_bug.cgi?
id=61775.
Comment 12 kpalagin 2007-04-05 10:19:10 UTC
Dup of 61775.
Resolving as such.

*** This issue has been marked as a duplicate of 61775 ***
Comment 13 kpalagin 2007-04-05 10:19:47 UTC
and closing.
Comment 14 nijungnile 2010-11-10 17:13:13 UTC
Created attachment 73416