Issue 56252 - Numbering style assigned to an unused paragraph style is not saved
Summary: Numbering style assigned to an unused paragraph style is not saved
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 680m134
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 54307 64856 (view as issue list)
Depends on:
Blocks: 59997
  Show dependency tree
 
Reported: 2005-10-19 07:41 UTC by kristov
Modified: 2013-08-07 14:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kristov 2005-10-19 07:41:44 UTC
Problem: If you assign a numbering style to a paragraph style and don't use it
at least once, it is not saved.

How to reproduce [I use the german localization, so some translactions might be
inaccurate]:
1) Create an empty text document.
2) Assign a numbering style to "Text Body" (e.g. Numbering 2).
3) Save and reload the document.
4) The numbering style of "Text Body" is reset to "None".

If you switched on the numbering for at least one "Text Body" paragraph (even if
you switched it off immediately afterwards), the bug does not occur.

This applies to OpenOffice.org 2.0RC3.

Note: This might be related to bug #56251.
Comment 1 michael.ruess 2005-10-20 16:11:45 UTC
MRU->OD: as described, a numbering style assigned to an para style which is
currently not used in the document will not be saved, at least it is not
available when reopening the document.
Comment 2 Oliver-Rainer Wittmann 2005-12-07 14:30:41 UTC
OD->AMA: Please take over as discussed.
Comment 3 Mathias_Bauer 2006-01-20 14:32:02 UTC
We will not be able to fix that one until code freeze for 2.0.2 -> retargetted
to 2.0.3
Comment 4 andreas.martens 2006-03-20 15:48:42 UTC
Fixed in CWS swqbf59
docstyle.cxx 1.22.178.1
Comment 5 andreas.martens 2006-03-20 15:56:02 UTC
*** Issue 54307 has been marked as a duplicate of this issue. ***
Comment 6 andreas.martens 2006-03-31 13:08:39 UTC
Ready for QA.
Comment 7 michael.ruess 2006-04-03 10:02:57 UTC
Checked fix in CWS swqbf59.
Comment 8 michael.ruess 2006-04-03 10:06:01 UTC
Verified fix in CWS swqbf59.
Comment 9 Oliver-Rainer Wittmann 2006-04-28 09:39:49 UTC
*** Issue 64856 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2006-05-09 16:22:40 UTC
Checked fix in 680m167.