Issue 56261 - Formulas do not fit the baseline of surrounding text
Summary: Formulas do not fit the baseline of surrounding text
Status: CLOSED DUPLICATE of issue 972
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: frank.loehmann
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-10-19 09:35 UTC by akio
Modified: 2005-11-03 19:24 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description akio 2005-10-19 09:35:54 UTC
How to reproduce:

1. Insert a formula using the Insert-Object-Formula menu command.
2. For testing purposes enter the formula: sum from{i} i^
3. Enter some text next to the formula.


Actual behaviour:

The baselines of the formula and of the text are not aligned.


Expected behaviour:

The baseline of the formula, i.e. the baseline of the second "i" in the example
given above, should be aligned with the baseline of the surrounding text.


Notes:

Note that this bug is *not* caused by misconfigured "Formula" stylesheet. The
underlying problem is located at a somewhat more fundamental level: Formulas in
OpenOffice are treated like any other graphics flowed into the text. As such, it
is not possible to vertically position them correctly (according to their
inherent baseline).
Comment 1 michael.ruess 2005-11-03 10:35:04 UTC
MRU->FL: the vetical-alignment problem of formula objects has been discussed for
a long time... Maybe in formulas we should implement something like a baseline
pointer e.g.
This could refer than  in the surrounding text.
Comment 2 lohmaier 2005-11-03 19:24:02 UTC
this one is a duplicate.

*** This issue has been marked as a duplicate of 972 ***
Comment 3 lohmaier 2005-11-03 19:24:28 UTC
closing duplicate.