Issue 56499 - en-dash and em-dash replacement
Summary: en-dash and em-dash replacement
Status: CLOSED DUPLICATE of issue 5018
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO 2.0 Beta2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: issues@lingucomponent
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-23 19:30 UTC by baszoetekouw
Modified: 2007-07-18 17:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description baszoetekouw 2005-10-23 19:30:47 UTC
Dash-replacement currently replaces -- by an em-dash and doesn't replace --- at
all. IMO, -- should be replaced by an en-dash and --- by an em-dash.
This is also the way it works in (La)TeX and even MS Word.
Comment 1 jallan3 2006-01-30 00:50:41 UTC
I have checked this on a Windows2003 installation which is scarcely used here at
work, presumably in pristine condition as installed.

Word replaces <space><hyphen><hyphen><space> by an en-dash surrounded by spaces
not an em-dash surrounded by spaces. It also replaces <normal
character><hyphen><hyphen><normal character> by an em-dash, exactly as does
OpenOffice Writer.

Possibly the version of MS Word being used by the previous poster has some
autocorrection enhancements.

See issue 61325 which provides what I believe is the rationale for MS Word's 
practice which OpenOffice Writer follows exactly.

That said, it would be a reasonable enhancement to automatically change a triple
hyphen into an em-dash, regardless of spacing around it, except when immediately
followed by ENTER key when being entered, which currently produces a full line
across the page and should continue to do so.
Comment 2 jallan3 2006-01-30 01:15:50 UTC
Note that in both MS Word and OpenOffice Writer, the combination
<space><hyphen><space> also resonably resolves to an en-dash surrounded by spaces.

The combination a triple-hyphen resolves to nothing in MS Word, regardless of
whether surrounded by spaces or other characters. The use of a triple hyphen for
a n m-dash and a double hyphen for n-dash is so far as I know limited to TeX
code and so intuitive only to a very small number of word processor users.
Comment 3 timar74 2006-01-30 07:13:24 UTC
See also issue #61005.
Comment 4 kpalagin 2007-05-23 21:07:50 UTC
I think this one belongs to Writer.
Comment 5 stefan.baltzer 2007-07-18 17:21:02 UTC
SBA: In my opinion, this one is a duplicate of enhancement issue 5018.

*** This issue has been marked as a duplicate of 5018 ***
Comment 6 stefan.baltzer 2007-07-18 17:24:13 UTC
SBA: Closed.