Issue 56502 - select all bug
Summary: select all bug
Status: CLOSED DUPLICATE of issue 17949
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Unknown
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-10-23 21:57 UTC by dwiniecki
Modified: 2005-11-06 00:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test Case (1.07 MB, application/msword)
2005-10-25 13:51 UTC, dwiniecki
no flags Details
file in which this error occurs (304.00 KB, application/msword)
2005-10-29 15:43 UTC, dwiniecki
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description dwiniecki 2005-10-23 21:57:33 UTC
When working on a native MS-Word document that contains an MS-Word formatted 
table of contents, the 'Select All' keyboard command, toolbar button and menu 
command selects only the table of contents and not the entire text of the 
document.

This occurs regardless where the cursor is inserted in the document.
Comment 1 yunkong 2005-10-25 10:02:29 UTC
Hello,

I tried this on OpenOfficeorg Writer 2.0 RC2 (Windows XP Professional, PC, 1.6 
GHZ, 512 MB RAM) but could easily select all text using the keyboard command ( 
CTRL + A). Only if I position the cursor within the table of contents does the 
select all command result in a selection of the table only.

Coould you provide the document you used so I can check against my build?

Thanks in advance,

A.Y.K. Jong 
Comment 2 dwiniecki 2005-10-25 13:51:52 UTC
Created attachment 30820 [details]
Test Case
Comment 3 yunkong 2005-10-25 16:03:26 UTC
Hello dwiniecki ,

Thanks for providing the document.

The problem however is that..

1. I can't open the document in Microsoft Word 2002. Word asks for a 
conversion program that I don't have installed at my work (and I don't have 
administrator privileges to install it).

2. I also can't open the document in Openofficeorg Writer 2.0. When I select 
the file to be opened in Writer a "Filter Selection" pops up.
Does this happen on your build? If so, what option should I choose? 

I can therefore not verify at the moment if the select all command only 
selects the table of contents.


A.Y.K. Jong
Comment 4 dwiniecki 2005-10-25 21:06:31 UTC
The test case file is saved in WinZip format.  Without compression, it would 
not fit under the 1MB limit indicated by the issue tracking system.
Comment 5 dwiniecki 2005-10-29 15:43:50 UTC
Created attachment 30993 [details]
file in which this error occurs
Comment 6 lohmaier 2005-11-06 00:51:38 UTC
duplicate.

*** This issue has been marked as a duplicate of 17949 ***
Comment 7 lohmaier 2005-11-06 00:52:08 UTC
closing duplicate.