Issue 56647 - Impress always copies first page
Summary: Impress always copies first page
Status: ACCEPTED
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-25 20:05 UTC by dontequila
Modified: 2017-05-20 11:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
File, where I am not able to copy pages (77.17 KB, application/vnd.sun.xml.impress)
2005-10-25 20:07 UTC, dontequila
no flags Details
The template was created with MS Powerpoint 2000 SR-1 (9.0.527)/German. (8.00 KB, application/vnd.ms-powerpoint)
2005-10-26 12:01 UTC, dontequila
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description dontequila 2005-10-25 20:05:49 UTC
Hi,

I attached a .odp file where I am not able to copy pages other than the first. 
Using German version of OOo Impress.

Tried this:
- added 3 pages to the presentation.
- select second page in page overview by clicking on it.
- hold Ctrl key and drag page to the bottom i.e. after page three.
- I get a new page but the content it a copy of page one

When I created a new empty presentation everything works fine. But with the 
attached file it does not work.

Regards,
Thomas

Btw. keep up the great work, it is an excellent software.
Comment 1 dontequila 2005-10-25 20:07:19 UTC
Created attachment 30830 [details]
File, where I am not able to copy pages
Comment 2 jlcheng 2005-10-26 06:28:46 UTC
Maybe slide name is same, so select 1st one. If you change the name of slides(no
same), application is ok.
Comment 3 wolframgarten 2005-10-26 07:45:27 UTC
The problem is reproducible. The root seems to be that all 3 slides have the
same name: Folie 1. When you give them individual names (A,B,C) then your
copying works.
Comment 4 groucho266 2005-10-26 08:48:05 UTC
Like WG said, the bug is that all three slides have the same name.  How can that
happen?
Comment 5 dontequila 2005-10-26 11:59:19 UTC
ok, seems that I found where the problem is based upon. The bug occurs when 
using a template created by MS Powerpoint. I attach a .pot file with one page. 
Creating a new Impress Presentation using that template, I copy the first page 
named "Folie 1" using drag&drop holding Ctrl key. After that I get two pages 
with the same name "Folie 1" and so on.
Comment 6 dontequila 2005-10-26 12:01:09 UTC
Created attachment 30862 [details]
The template was created with MS Powerpoint 2000 SR-1 (9.0.527)/German.
Comment 7 dontequila 2005-11-07 14:58:46 UTC
What's going on now for this issue?

Do I need to move it to another topic?
Comment 8 clippka 2005-11-08 16:14:07 UTC
dontequila,

thanks for submitting this issue. The problem is understood, but the issue
itself is not severe enough to be fixed asap. As you may noticed we have many
open issues to solve for OOo and they are worked at by priority. So this may
take some time now.

I know that this issue may be very important for you, but please consider that
this issue is part of OOo since 5 years and part of StarOffice some years longer
and you are the first one who stumbles over this.
Comment 9 dontequila 2005-11-08 18:31:00 UTC
hey, no problem...it's not that important for me, since I now know how to go 
around....just wanted to make sure that it's not lost in space ;-)

Many thanks,
Thomas
Comment 10 zhujia 2006-01-27 05:09:29 UTC
I am able to reproduce this defect using Windows XP SP2, and the version is 
OOo2.0

The replication steps are taken as following:
1.download the test.odp file provided by the reporter here: 
http://www.openoffice.org/nonav/issues/showattachment.cgi/30830/test.odp
2.Double click on the file downloaded and it opened in an Impress application.
3.While holding the Ctrl key on the keyboard, left click on slide 2 on the 
left panel and drag it down under slide 3. 
4.Now slide 2 should be copied at slide 4 position. 
5.But if you exam it carefully, you will notice that actually slide 1 is 
copied.

This bug seems uneasy to replicate. During the follow-up tests, I tried opened 
a new Impress application and tried to copy the slides using the method 
mentioned above in step 3 and 4. I failed since apparently the application 
automatically assigned the name of the slides as slide 1, slide 2, slide 3 and 
so on. And so far I have not find a way to change the name of the slides. 
Also I tried to replicate this bug on Linux 2.4.31 with OOo2.0, and I am able 
to replicate the bug on that system too. 
Comment 11 Marcus 2017-05-20 11:08:27 UTC
Reset assigne to the default "issues@openoffice.apache.org".