Issue 56651 - Crash (segfault) opening RTF file
Summary: Crash (segfault) opening RTF file
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
: 56536 59168 (view as issue list)
Depends on: 59345
Blocks:
  Show dependency tree
 
Reported: 2005-10-25 20:34 UTC by leonstr
Modified: 2013-08-07 14:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
RTF file that causes crash (shows layout for ACM papers). (68.52 KB, text/rtf)
2005-10-25 20:36 UTC, leonstr
no flags Details
Stack trace from official 2.0 m139 RPMs, Fedora Core 4 x86-32 (10.43 KB, text/plain)
2005-11-24 16:27 UTC, aziem
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description leonstr 2005-10-25 20:34:56 UTC
I get a crash when I try to open a specific RTF file using OOo 2.0 on Fedora
Core 4 (GNOME desktop).

Although this may be related to 56536 and/or 53543 I do *not* get a crash with
the test documents posted with these issues.

If launched from the console, when the crash occurs I see:
/usr/lib/openoffice.org2.0/program/soffice: line 145:  3795 Segmentation fault 
   "$sd_prog/$sd_binary" "$@"

I do not get this problem when I open the file in OOo 2.0 on Windows XP Pro SP1.
Comment 1 leonstr 2005-10-25 20:36:48 UTC
Created attachment 30833 [details]
RTF file that causes crash (shows layout for ACM papers).
Comment 2 michael.ruess 2005-10-26 10:59:01 UTC
MRU->US: can you please have a look? On my WinXP and Suse 9.3 the file opens
fine. Maybe a Font-issue on FC4? In the doc, Times New Roman is used...
Comment 3 caolanm 2005-10-26 11:34:45 UTC
*** Issue 56536 has been marked as a duplicate of this issue. ***
Comment 4 aziem 2005-11-24 16:27:36 UTC
Created attachment 31776 [details]
Stack trace from official 2.0 m139 RPMs, Fedora Core 4 x86-32
Comment 5 aziem 2005-11-24 16:29:15 UTC
Confirmed: see stack trace.
Comment 6 ulf.stroehler 2005-11-24 19:24:08 UTC
crash in rtf parser (not yet reproduced).
does not crash in latest m142 build on Solaris10 X86.
haven't tried my fc4 linux box sofar as it' s currently under heavy load.

@submitter: could you provide the locale of your desktop session where the
problem occurs pls. Type "locale" in a shell. Thx.
Comment 7 ulf.stroehler 2005-11-25 07:28:03 UTC
grr REPRODUCED with m142/Linux fc4.
this one is great fun because it crashes each time the document is recovered
without the chance to ever see or submit a crash report.
Currently *only* reproducible on fc4 (locale is en_US.UTF-8).
Comment 8 leonstr 2005-11-25 19:16:47 UTC
Output from "locale" as requested:

LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
Comment 9 andreas.martens 2005-12-06 08:58:33 UTC
I got exceptions even under Windows => reproducible.
Comment 10 michael.ruess 2005-12-12 11:33:53 UTC
*** Issue 59168 has been marked as a duplicate of this issue. ***
Comment 11 loic.breilloux 2005-12-13 09:22:56 UTC
reproductible on windows 2k and OOo v2.0.1RC4
Comment 12 andreas.martens 2005-12-14 15:31:57 UTC
Fixed in 
sw/source/filter/rtf/rtffly.cxx 1.21.28.1
sw/source/core/layout/layact.cxx 1.54.68.1
Comment 13 andreas.martens 2005-12-22 15:50:39 UTC
AMA->MRU: Checked in internal installation set of cws swqbf48 - please verify.
It's the same effect like issue #59345#, the graphic get lost and an automatic
spellchecking or autocompletion will cause a crash later on.

re-open issue and reassign to mru@openoffice.org
Comment 14 andreas.martens 2005-12-22 15:51:14 UTC
reassign to mru@openoffice.org
Comment 15 andreas.martens 2005-12-22 15:51:20 UTC
reset resolution to FIXED
Comment 16 michael.ruess 2006-01-18 13:57:39 UTC
Verified fix in CWS swqbf48.
Comment 17 michael.ruess 2006-02-22 11:53:37 UTC
Checked fix in OO 2.0.2rc2 build.