Issue 56920 - Auto-increment always starts from zero
Summary: Auto-increment always starts from zero
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P4 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-29 12:09 UTC by Andrea Pescetti
Modified: 2009-07-28 17:15 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2005-10-29 12:09:58 UTC
1. Create a new database.
2. Create a Table using the wizard: add a primary key with auto-increment.
3. Add data.

The auto-generated value of the primary key field for the first record is zero.

Not a bug in itself, but setting the default first entry to 1 would enhance
compatibility. MySQL starts from 1, for instance.

An option to specify a start value would do as well.

[Reported by Mario Govoni during Italian QA tests]
Comment 1 christoph.lukasiak 2005-11-08 14:18:45 UTC
i can acknowledge that

send further to: requirments
Comment 2 marc.neumann 2005-11-09 08:37:26 UTC
Hi,

according to the hasql db documentation at 
http://hsqldb.org/doc/guide/ch09.html#create_table-section
You can change the start of the autoincrement field when creating the table via
sql. (menu: TOOLS / SQL)

In the OOo tabledesign there is no possibility to set the start parameter yet.

Bye Marc
Comment 3 Mechtilde 2009-07-28 17:14:37 UTC
no response since that time
-< invalid
Comment 4 Mechtilde 2009-07-28 17:15:19 UTC
.
Comment 5 Mechtilde 2009-07-28 17:15:53 UTC
-> closed