Issue 57004 - macro recorder does not work in embedded Base forms
Summary: macro recorder does not work in embedded Base forms
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P4 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2005-10-31 01:43 UTC by drewjensen.inbox
Modified: 2013-02-07 22:41 UTC (History)
2 users (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---

Database with NewCompany form for testing (30.54 KB, application/vnd.sun.xml.base)
2005-10-31 17:32 UTC, drewjensen.inbox
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drewjensen.inbox 2005-10-31 01:43:52 UTC
The macro recorder does not function within the Base embedded forms.

The RFE is simply to make it do so.
Comment 1 marc.neumann 2005-10-31 08:50:49 UTC

I can use the macro record inside an form (Design / Use). 
What exactly to you want to record? May be the macro recorder can't record this.
The macro recorder can only record very basic functions.

Bye Marc
Comment 2 drewjensen.inbox 2005-10-31 17:30:54 UTC
I have a Base database with embedded forms. (I will attatch it)

I open a form. Start the Macro recorder.

Type some text into the first text box. Tab to the next. Type some more text.
Tab again. Type text into the third text box.

Stop recorder.

The macro box goes away - no offer to save the macro anywhere. Maybe I am just
missing something. Others on the OOOForum site are bringin up the same problem.

My environment is WinXP HE SP2 - JRE 1.4.2_07

I saved the form to a odt file. Fixed up the database connection and tried the
same thing. Same result. When I end recording I have no option to save the macro

Maybe I am just missing something?
Comment 3 drewjensen.inbox 2005-10-31 17:32:28 UTC
Created attachment 31057 [details]
Database with NewCompany form for testing
Comment 4 marc.neumann 2005-11-01 08:17:19 UTC

The Macro recorder can't record the things you want to record. When you create a
new record or save a record then the macro can be record and then a dialog to
save the macro appear also.

The macro record can only record very very simple things.

I set this issue to WORKSFORME now.

Bye Marc
Comment 5 drewjensen.inbox 2005-11-01 21:18:51 UTC

I am lost here. If I open writer, start the macro recorder and enter text then
stop the recorder I am prompted to save the macro. This macro includes all my
text entry - including fixing typos -.

So if I want some canned phrases for database form entry the recorder can't do it.

If you can record keystrokes for characters in Writer then why deny the same
capability to Base users.
Comment 6 christoph.lukasiak 2006-06-12 15:39:47 UTC
this behavior can be wanted
Comment 7 christoph.lukasiak 2006-06-12 15:51:43 UTC
send further to requirements
Comment 8 Rob Weir 2013-02-02 02:59:50 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the