Issue 57162 - Nested table does not convert to WW8 format
Summary: Nested table does not convert to WW8 format
Status: CLOSED DUPLICATE of issue 25680
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.0
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-01 23:41 UTC by scotty
Modified: 2008-08-24 08:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Nested table doc created in OpenOffice.org 2 (8.13 KB, application/vnd.oasis.opendocument.text)
2005-11-01 23:44 UTC, scotty
no flags Details
Document after converted to WW8 (10.00 KB, application/msword)
2005-11-01 23:45 UTC, scotty
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description scotty 2005-11-01 23:41:51 UTC
The new "nested table" feature in OpenOffice.org 2 does not convert to Microsoft
Word format. Tested on MS Office 2003.

1. New document in OO.o Writer
2. Create two tables 2x2 tables, one nested inside another
3. Save as Word format
4. Open the saved file in Word. Inner table stays, but each cell in outter table
gets converted to paragraphs. See attached documents for details.

Note -- sometimes it is the other way around. Outter table stays, but inner
table disappears.

Also, if nested table is created in MS Office 2003, and the .doc is imported
into OpenOffice.org 2, inner table will be wrapped around a frame object. For
example, instead of

<table:table-cell>
  <table:table/>
</table:table-cell>

You get something like

<table:table-cell>
  <text:p>
    <draw:frame>
      <draw:text-box>
        <table:table/>
      </draw:text-box>
    </draw:frame>
  </text:p>
</table:table-cell>

Which is not what I expect...
Comment 1 scotty 2005-11-01 23:44:35 UTC
Created attachment 31096 [details]
Nested table doc created in OpenOffice.org 2
Comment 2 scotty 2005-11-01 23:45:17 UTC
Created attachment 31097 [details]
Document after converted to WW8
Comment 3 michael.ruess 2005-11-02 06:31:44 UTC
Known problem, see issue 25680.

*** This issue has been marked as a duplicate of 25680 ***
Comment 4 michael.ruess 2005-12-08 15:18:06 UTC
Closing duplicate.
Comment 5 Rainer Bielefeld 2008-08-24 08:43:20 UTC
Can't see any "open-import" relation