Issue 57547 - Right click menu on sheet tab disappears off screen on multimonitor configuration with different screen resolutions
Summary: Right click menu on sheet tab disappears off screen on multimonitor configura...
Status: CLOSED DUPLICATE of issue 59525
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0
Hardware: All Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-09 08:00 UTC by quintinwillison
Modified: 2008-11-05 20:52 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
My Windows XP Display Properties (8.63 KB, image/png)
2005-11-09 08:06 UTC, quintinwillison
no flags Details
The entire desktop (Print Screen) to illustrate the virtual dead space below the secondary display in to which the right menu disappears (109.51 KB, image/png)
2005-11-09 08:10 UTC, quintinwillison
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description quintinwillison 2005-11-09 08:00:27 UTC
I'm running dual-head (multi-monitor) with my primary display (#1) set at a
resolution of 1920x1200 (my laptop TFT panel) and my second display (#2) set at
a lower resolution of 1280x1024 and positioned to the right of the primary
display.  The X,Y coordinates of the top left of the second display are thus
1920,0 in world desktop coordinate space.

I've got OpenOffice Calc maximised on the second display.  If you right click on
one of the Sheet tabs at the bottom of the Calc window to get the right click
menu to rename a sheet you can only see the Insert Sheet and Delete Sheet
options as the rest of the menu disappears off the bottom of screen!

The only way to get round this is to restore the window (un-maximise) and move
it up the screen or back on to the primary monitor.

Does OpenOffice evaluate "visible screen area" by the ENTIRE desktop bounds or
on a per-display basis as it should do?  I know (as a Microsoft .NET developer
myself) that it's possible to enumerate and retrieve the bounds for all the
displays on Windows - but I'm not sure how this would be achieved in OpenOffice
due to the cross-platform thing.

I have tested this on Microsoft Excel and it handles these kind of popup menus
correctly no matter which display the app is on and regardless of whether it's
maximised or not.
Comment 1 quintinwillison 2005-11-09 08:06:32 UTC
Created attachment 31287 [details]
My Windows XP Display Properties
Comment 2 quintinwillison 2005-11-09 08:10:34 UTC
Created attachment 31288 [details]
The entire desktop (Print Screen) to illustrate the virtual dead space below the secondary display in to which the right menu disappears
Comment 3 frank 2006-02-17 10:18:33 UTC
Hi Thorsten,

could you check this please ?

Thanks
Comment 4 tyamadajp 2007-02-24 04:55:42 UTC
I'm also hit by this bug.
Running latest OOo 2.1 (ja), on Windows XP SP2.
Comment 5 gercokees 2007-04-05 10:34:08 UTC
since 2 people ran into the same bug, this should be confirmed...
ofcourse, it would be a good idea to check with the latest OOo as well... maybe
some of the other describers could do that?
Comment 6 kpalagin 2007-05-24 22:47:15 UTC
dualmonitor issue
Comment 7 paul.m.nz 2007-06-26 03:56:54 UTC
This is a duplicate issue of 59525.

*** This issue has been marked as a duplicate of 59525 ***
Comment 8 Mechtilde 2008-11-05 20:52:59 UTC
close the duplicate