Issue 57585 - Prefer OLE format if only OLE and Metafile are offered by clipboard
Summary: Prefer OLE format if only OLE and Metafile are offered by clipboard
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOO 2.0 Beta2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-09 15:27 UTC by acutron
Modified: 2013-02-07 22:40 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
File containing what should be an autocad doc (14.43 KB, application/vnd.sun.xml.writer)
2005-11-10 10:40 UTC, acutron
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description acutron 2005-11-09 15:27:09 UTC
When you upgrade from 1.1.* to 2.0 and you have an embedded autocad object
inside a document this is not seen by office as an autocad OLE object but as an
image file.
Comment 1 michael.ruess 2005-11-09 20:10:39 UTC
As long as we do not have AutoCad here, could you please attach such an sxw
document which shpws the mentioned problem in OO 2.0? Thanks a lot!
Comment 2 acutron 2005-11-10 10:40:14 UTC
Created attachment 31322 [details]
File containing what should be an autocad doc
Comment 3 acutron 2005-11-10 10:48:33 UTC
This is obscure, got files produced by 1.1.x where attachments are intact, I
tried to open the file on 1.1.x and the result is the same. Somehow during
editing the drawing has been converted to a metafile, I will investigate this
further. What I noticed is that to correctly insert an autocad file into 2.0 I
can't use Insert/Ole Object/Create from File as I did before. Have to open Acad,
do a select all on the drawing and paste it in Open Office. That produces a
correct document with an embedded acad file.
Comment 4 acutron 2005-11-10 11:07:47 UTC
OK, got some more info...If you do a edit copy/paste from autocad into oowriter
2.0, you get a metafile.If you do a paste special and you choose autocad you get
one of 2 behaviours:

1. A very small drawing is produced, if you click on it acad is invoked and you
may do a zoom extents and update, the drawing looks correct in size.

2. acad is invoked and if you close it the drawing is correct in size.

This is nevertheless still nebulous. I opened the sxw as a zip to look at the
components and coudn't draw any conclusion, cause my knowledge of the formats is
not enough.
Comment 5 michael.ruess 2005-11-15 15:06:56 UTC
Problem here was, that in the Clipboard only Metafile and OLE format are
offered. Writer here prefers the Graphic format, but it could also make sense to
prefer the OLE format of course.

Reassigned to requirements to consider.
Comment 6 ace_dent 2008-05-16 01:41:03 UTC
OpenOffice.org Issue Tracker - Feedback Request.

The Issue you raised is currently assigned to 'Requirements' pending review, but
has not been updated within the last 2+ years. Please consider re-testing with
one of the latest versions of OOo, as the problem(s) may have already been
addressed. Either use the recent stable version:
http://download.openoffice.org/index.html
or consider trying the new OOo 3 BETA (still in testing):
http://download.openoffice.org/3.0beta/
 
Please report back the outcome so this Issue may be Closed or Progressed as
necessary - otherwise it may be Resolved as Invalid in the future. You may also
wish to search for (and note) any duplicates of this Issue that may have
advanced further by checking the Issue Tracker:
http://www.openoffice.org/issues/query.cgi
 
Many thanks,
Andrew
 
Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~
http://marketing.openoffice.org/3.0/announcementbeta.html