Issue 5773 - printing envelopes
Summary: printing envelopes
Status: CLOSED DUPLICATE of issue 20057
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: PC Windows 2000
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-06-12 19:42 UTC by dubois
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dubois 2002-06-12 19:42:53 UTC
I often print envelopes when I print letters, and it's a very cumbersome 
process.  I have to select the address in the letter, then hit "Insert - 
Envelope," then hit the Envelope tab, then paste the address into 
the "Addressee" box, then hit the Printer tab, then hit the Setup button, then 
go through about three steps to ensure that my HP LaserJet 1100 knows that I 
want to print an envelope instead of a letter, then come back to the Envelope 
box to hit the New Doc. button, where I find the address squished inside a 
frame with borders.  So then I have to select the frame, drag the left side to 
the left to unsquish the address, then go to the format window to get rid of 
the borders, then print.  And I have to do all this every time.  When I finally 
get it right, I try to save it as its own document so I can use it again, but 
this only works sometimes; mostly, when I reopen such a saved document, I see 
an elongated frame with no text in it.  There ought to be a better way to make 
envelopes from letters, particularly since an envelope will be needed with most 
every letter.
Comment 1 stefan.baltzer 2002-11-25 13:34:06 UTC
Reassigned to Christian.
Comment 2 Unknown 2002-11-29 19:02:34 UTC
I hate to make the comparision, but the MS Office envelope wizard is 
an excellent implementation of this functonality.  I have personally 
moved all my word processing with the exception of ad hoc envelope 
printing to OOo.  For me, it is the last thing holding me back from 
uninstalling that POS.
Comment 3 christian.jansen 2003-03-24 07:54:17 UTC
Reassiged to Bettina.
Comment 4 7kaltoid 2003-08-12 12:19:49 UTC
Over a year later and using 1.1rc2, I don't see that anything has 
changed from this original post.

All of the functions for printing envelopes in association with a 
document are disasters.  Printing a single envelope is as messy as it 
can be and still function at all.

Proper performance of this type of function is far more essential to a 
typical user than more exotic issues such as inserting MPEGs into 
presentations.
Comment 5 Unknown 2003-10-02 07:03:07 UTC
This should probably have issue type "DEFECT" given how bad envelope
creation is. It's nigh unusable in its current state, and it's a
problem that would keep OOo off just about any secretary's desk. Not
to mention this bug has been open a LONG time without being addressed.

It would be better implimented as a template with the two text fields
to fill/autofill and automatically set printer settings for that one page.

If possible, the insert envelope menu item could be reworked to simply
insert a copy of this template, gleaning sender/addressee information
from the current document if available, otherwise falling back to user
info for sender & blank addressee. eg: A "letter" template has a
sender and an addressee field and you insert an "envelope" template,
which can be fully completed automatically (with the envelope fields
still writable in case the user wants to make changes, of course).
Last but not least, the template should be available in "new document
from template", since sometimes people just want to print out an envelope.

Hopefully it's actually possible to do this, as well as have the
different printer settings for the envelope page and the rest of the
letter.
Comment 6 bettina.haberer 2003-10-10 13:35:17 UTC
Printing envelopes is very copious. We should try it for OO.o 2.0, so
I keep it on this target.
Comment 7 bettina.haberer 2004-04-08 21:37:55 UTC
PLease have a look at PCD 20057 for OO.o 2.0.

*** This issue has been marked as a duplicate of 20057 ***
Comment 8 bettina.haberer 2004-04-08 21:38:10 UTC
closed.
Comment 9 jfrorie 2008-02-20 20:12:29 UTC
I have looked at 20057 and this is not a duplicate.  20057 deals with mail
merge, the combining of external data sources with a document template.  The
feature that is being asked for is an ability to quickly print an envelope
within writer.  W*rd has this ability and it is used frequently by people that
need to quickly address an envelope without sitting down and fashioning a
template, measuring the printing areas, etc.  

As an additional factor, people with limited dexterity use this feature to
address envelopes when they are unable to properly address one by hand.

I'd like to see this reopened.
Comment 10 unordained 2009-09-10 17:38:51 UTC
I agree with jfrorie -- 20057 is not a duplicate, this should be reopened. 

I know my users love Word's "make an envelope out of this" feature, and I'll
have trouble getting them to switch (to 3.1) without it; they're generating tons
of individual documents per day, and many of them need envelopes (but it's not
part of the existing merge.) Law firms are like that.

Word's feature takes either your current text selection, or the block of text
the caret is currently in, as long as it's a 3+ line block of text, or finds the
first 3+ line block of text in the document (in that order.) Maybe that's not
perfect, OOO should do its own thing, but it's certainly a much faster way for
users to setup an envelope after they've fixed up a letter. No copy-pasting
required. Also: Word allows you to print the envelope/label without
appending/inserting it into the current document or creating a new document for
it. My users don't really care to keep the resulting envelope, but they do
intend to archive the letter.

All of this applies to one-off labels, too.