Issue 57857 - linked cell property incorrectly imported for option button form control
Summary: linked cell property incorrectly imported for option button form control
Status: CLOSED DUPLICATE of issue 30823
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO 2.0 Beta2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: daniel.rentz
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-14 10:08 UTC by noel.power
Modified: 2005-12-21 15:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
file to demonstrate issue (13.50 KB, application/vnd.ms-excel)
2005-11-14 10:17 UTC, noel.power
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description noel.power 2005-11-14 10:08:50 UTC
np->dr
Hi you might be interested in this ;-) If you create an option button ( form
control ) in xl, change it's properties to set it's linked cell, then
subsequently create a number of other option buttons, the imported behavior in
calc is quite different from xl. Seems there are two problems with the import
1) only the first cell has the linked cell attribute set, the other ( two option
buttons e.g. in the sample doc... which I will attach ) don't have this property
 set. So I guess in for this, the import dosn't take into account the grouping (
implicit in this case )

2) the value of the linked cell when the option button is set/unset is
incorrect. in calc this is set to true/false, in xl it seems to be set to 1 or 0
or in the case of a an option button group. the value of the linked cell is 1 ->
no. of option buttons. e.g. for a set of three option buttons see the expected
values in the table below

option 1     option 2    option 3        linked cell val
   X             0          0                   1
   X             x          0                   2
   0             0          x                   3
Comment 1 noel.power 2005-11-14 10:17:57 UTC
Created attachment 31463 [details]
file to demonstrate issue
Comment 2 noel.power 2005-11-14 14:14:55 UTC
of course the table should look like this

option 1     option 2    option 3        linked cell val
   x             0          0                   1
   0             x          0                   2
   0             0          x                   3
Comment 3 daniel.rentz 2005-11-14 14:47:52 UTC
There are two kinds of option buttons in Excel:

- Old form controls from MSOffice 5.0/95: If linked to a cell, the cell refers to the 
entire group and will contain the 1-based index of the selected option button or 0, if 
no button is selected initially (even in a group; a single option button is just a 
special case of a group).
- New ActiveX form controls (MS Forms 2.0): If linked to a cell, the cell will contain 
TRUE/FALSE for exactly one option button (not linked to the group).

Anyway, the Excel filters lose grouping information for option buttons. This is 
already addressed in issue 30823.

*** This issue has been marked as a duplicate of 30823 ***
Comment 4 daniel.rentz 2005-12-21 15:03:08 UTC
closed