Issue 57936 - Color of invisible Layers name not blue after re-opening file
Summary: Color of invisible Layers name not blue after re-opening file
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: PC Windows, all
: P3 Minor with 1 vote (vote)
Target Milestone: AOO Later
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
: 58701 59699 59700 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-11-15 14:44 UTC by janriel
Modified: 2017-05-20 10:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.1
Developer Difficulty: Simple
jsc: 4.1.0_release_blocker-


Attachments
Example File (odg). Color of layer's name is black after opening but should be blue (31.59 KB, application/vnd.sun.xml.draw)
2005-11-15 14:46 UTC, janriel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description janriel 2005-11-15 14:44:00 UTC
After setting a layer to "not visible" in OODraw the color of the layer's name
in the tab (hope "tab" is the right expression. In German it's called
Karteireiter) is switching to blue (very helpful feature using lots of layers). 
After saving, closing and re-opening the file, the layer's names are set all to
black again, no matter if the layers are visible or not. After switching the
visability-status of one layer the color re-appears.

If an example-file is desired I can load one up.

Regards, 

Jan Riel
Comment 1 janriel 2005-11-15 14:46:01 UTC
Created attachment 31517 [details]
Example File (odg). Color of layer's name is black after opening but should be blue
Comment 2 wolframgarten 2005-11-15 14:55:53 UTC
Something's wrong here: if I click with SHIFT on one of the leyers after freshly
opening the doc all others get blue (?). Reproducible.
Comment 3 wolframgarten 2005-12-01 08:44:53 UTC
*** Issue 58701 has been marked as a duplicate of this issue. ***
Comment 4 wolframgarten 2006-01-03 12:25:56 UTC
*** Issue 59700 has been marked as a duplicate of this issue. ***
Comment 5 wolframgarten 2006-01-03 12:29:35 UTC
*** Issue 59699 has been marked as a duplicate of this issue. ***
Comment 6 Rainer Bielefeld 2013-10-31 11:53:35 UTC
STILL reproducible with server installation of "AOO 4.1.0-Dev – English  UI / German locale - [AOO410m1(Build:9750)  -  Rev. 1536316 - 2013-10-30]" on German WIN7 Home Premium (64bit)", own separate user profile; because of incomplete LCo selector (Bug 123063) no correct information can be left.

I remove groucho266 from Assignee due to facts

Remove TM AOO Later - actual currently: AOO Never ;-)
Comment 7 Armin Le Grand 2014-02-28 20:26:37 UTC
Old German saying: Better late than never :-)

I added code in DrawViewShell::ReadFrameViewData to again refresh the LayerTabBar in the call to ChangeEditMode. It gets only initialized once (too early), but needs that refresh when the Later's visibility was set at the SdrPageView (done in that method). Checking if that works...
It does, preparing commit, grepping. Have to set back to 'AOO Later' since I do not know if it will make it to AOO4.1.0...
Comment 8 SVN Robot 2014-02-28 20:27:33 UTC
"alg" committed SVN revision 1573062 into trunk:
i57936 Added refresh to update LayerTabBar when attributes like Layer visibil...
Comment 9 Armin Le Grand 2014-02-28 20:28:46 UTC
Commited, done. Asking for 4.1.0 release blocker to get it to the AOO4.1 beta, it's a safe fix that does not hurt and cleans up an annoyance.
Comment 10 jsc 2014-03-03 08:14:16 UTC
showstopper means that we want only serious or really important issues fixed on the release branch. We have too often introduced regressions with so called easy fixes. Either we accept the showstopper mode or we fix issues until the last minute.

From my understanding this is no showstopper for 4.1.
Comment 11 jsc 2014-03-03 12:22:57 UTC
don't grant showstopper flag