Issue 58179 - An easier way of aligning "=" relative to the line above
Summary: An easier way of aligning "=" relative to the line above
Status: CLOSED DUPLICATE of issue 5998
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P4 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-11-19 21:45 UTC by alsuren
Modified: 2005-11-20 00:50 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description alsuren 2005-11-19 21:45:46 UTC
At present, the only way I've seen to align "=" signs is to use a matrix or 
the phantom{} function. This is about the only reason my maths teacher could 
give for teaching us the MS word equation editor rather than OOo math. 
 
 
 
I think it would be elegant to have a function called align(){} 
 
 
#######Proposed behaviour########: 
If I type 
 
align(=) 
{ 
V = 2 * B newline 
= 2 * 6 newline 
= 12 
} 
(note the = inside the ()) 
 
Then it should render as 
V = 2 * B  
  = 2 * 6  
  = 12 
with all the = signs lining up 
 
 
and if I type 
align("") 
{ 
z = 3 a + ""4 b + 8 c + d + 32 e + 16 f newline 
""+ 18 g + 26 h 
} 
 
then it would render as 
z = 3 a + 4 b + 8 c + d + 32 e + 16 f 
          + 18 g + 26 h 
with the first "" on the bottom line lined up with the first "" on the line 
above it, thereby making the 4 and the + line up 
 
This is an idea similar to LaTeX, which has the invisible character "&" as the 
alignment tab ( see 
http://www.maths.tcd.ie/~dwilkins/LaTeXPrimer/Multiline.html ), but I don't 
know what & is used for in OOo
Comment 1 lohmaier 2005-11-20 00:50:08 UTC
duplicate.

*** This issue has been marked as a duplicate of 5998 ***
Comment 2 lohmaier 2005-11-20 00:50:42 UTC
I will copy your proposal to the other issue.

closing duplicate.