Issue 58281 - Cannot add hyphenated words to custom dictionary
Summary: Cannot add hyphenated words to custom dictionary
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2005-11-22 08:28 UTC by stowrob
Modified: 2013-08-07 14:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description stowrob 2005-11-22 08:28:39 UTC
When the spellchecker dialog stops on a word that it thinks is incorrect, that
word is highlighted in red and that is the *ONLY* thing you can add to a
dictionary with the ADD button.  That is no good if it is part of something like
a compound word and you want to add the whole thing to the dictionary and not
the individual parts.

Examples: (Using English-UK)

1.)  Spellchecker stops on "tac-nuke" and highlights "tac".  I want to add
"tac-nuke" to the dictionary because I want "tac" to still be considered a
probable error in any other context.

2.)  Spellchecker stops on "Semper Fi" and highlights "Semper".  I want to add
"Semper Fi" to the dictionary, because I want "Semper" and especially "Fi" to
still be considered probable errors in any other context.

3.) "Gung ho".

4.) "itsy-bitsy"

5.) "pac-man"

6.) "repl-depl"

And I shudder to think of what people using OO for technical writing are going
through when they find that they can't add things to a dictionary like 

Using the "Semper Fi" example, I have tried using the mouse to select "Semper
Fi" before clicking the Add button, but it does not work.  And I was surprised
that there is no "Add" action of any kind on the context menu if I right-click
on either the word Spellchecker highlighted or something I selected.

If there is better alternate way to add things to a dictionary, it is not
mentioned in the help and I can't find it in the menus.  

I have tried manually editting en_GB.dic, but whether I do it with WordPad,
NotePad, or Borland Delphi 6, OpenOffice 2.0 barfs next time I try to start it
up.   And that method would be pretty cumbersome even if it worked because you
have to shut down and restart OO every time you want to add a word.

Off Topic:  If you click the HELP button in the Spellchecker Dialog wouldn't you
expect it to display help about the spellchecker ?
Comment 1 h.ilter 2005-11-22 13:09:18 UTC
Reassigned to SBA
Comment 2 atdsm 2006-02-03 13:41:27 UTC
Confirmed - Windows XP SP2, OOo 2.0.1. Cannot add a hyphenated word to the
dictionary by right clicking on it.

I think the underlying problem here is how OOo parses words for checking them in
the dictionary. OOo seems to divide words at punctuation, including hyphens.
Thus hyphenated words are treated as two words.

@stowrob, To answer one of your questions, yes, there is a way to edit the
dictionary from within OOo. Go to the "Tools" menu and select "Options." In the
navigation list, select "Language Settings" -> "Writing Aids." In the center of
the panel will be a list of dictionaries. You can turn them on or off, add new
dictionaries, or edit existing dictionaries. Editing an existing dictionary will
allow you to add words with hpyhens.

BUT, adding a word with a hyphen still does not cause OOo to recognize the word.
If I add "itsy-bitsy," for example, the spell checker still catches it as two
words, rather than as a single word. Same with words like "Semper Fi."

Expected Behavior: Custom Dictionary entries with spaces or hyphens should be
consulted when determining if a word is misspelled. User should be able to add
hyphenated misspelled words to the dictionary by selecting the entire word and
rightclicking on it (or something similar).

Off Topic: In my version (OOo 2.0.1), the "Help" button does display help about
spellcheckers. If it doesn't on yours, file a seperate issue. :)
Comment 3 stefan.baltzer 2006-04-05 10:34:41 UTC
Reassigned to TL
Comment 4 thomas.lange 2009-09-15 12:41:23 UTC
tl->sba: Should be implicitly fixed because of the latest OOo 3.2 breakiterator
change. Please check.
Comment 5 Raphael Bircher 2011-10-04 22:39:15 UTC
Reassigne to the default contact.

rbircher > sba feel free to reassigne to your self.

This issue should be solved in a newer version like OOo 3.3

Maybe sameone can check it.