Issue 58308 - use jaxp api for helpcontent building utilities
Summary: use jaxp api for helpcontent building utilities
Status: CLOSED FIXED
Alias: None
Product: utilities
Classification: Unclassified
Component: code (show other issues)
Version: 680m141
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 2.0.2
Assignee: andreas.bille
QA Contact: Unknown
URL:
Keywords:
: 57284 (view as issue list)
Depends on: 57545
Blocks: 52974 59985
  Show dependency tree
 
Reported: 2005-11-22 13:39 UTC by caolanm
Modified: 2006-03-24 09:02 UTC (History)
7 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
jaxp api using patch (25.10 KB, patch)
2005-11-22 13:40 UTC, caolanm
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2005-11-22 13:39:43 UTC
XmlSearch and xmlhelp use some sun.com.* stuff which is available only for sun
java but provided for older versions of sun java and non sun java through the
use of jaxp.jar and parser.jar. The following proposed patch uses the final jaxp
api instead.

The advantage is that this api is also provided for by jaxp.jar and parser.jar,
but allows those .jars not to be used if the java being used to build OOo has
builtin jaxp api support. This would enable some distributions which are nervy
about using sun java components to build OOo to avoid parser.jar and jaxp.jar.
Comment 1 caolanm 2005-11-22 13:40:32 UTC
Created attachment 31714 [details]
jaxp api using patch
Comment 2 caolanm 2005-11-22 13:48:04 UTC
cmc->abi: Not sure who owns XmlSearch/xmlhelp to perhaps give this a review
Comment 3 caolanm 2005-11-22 13:48:46 UTC
cmc->abi: Not sure who owns XmlSearch/xmlhelp to perhaps give this a review
Comment 4 sparcmoz 2005-11-26 11:02:33 UTC
*** Issue 57284 has been marked as a duplicate of this issue. ***
Comment 5 caolanm 2006-01-17 10:38:43 UTC
in progress
Comment 6 caolanm 2006-01-17 13:08:11 UTC
committed to workspace jaxpapi
Comment 7 caolanm 2006-01-20 14:18:21 UTC
reopen for qa
Comment 8 caolanm 2006-01-20 14:19:06 UTC
reassign for qaing
Comment 9 caolanm 2006-01-20 14:19:30 UTC
done in jaxpapi workspace
Comment 10 svante.schubert 2006-02-06 18:18:13 UTC
We should think about an follow up enhancement, the update of the Xalan version
from 2.6 to 2.7. Heard from various sides, that the 2.7 version has a very good
condition.

Furthermore, they added JAXP 1.3 and Namespace/XML 1.1

http://xml.apache.org/xalan-j/readme.html#done

The downside:
Apache splitted the serializer.jar from xalan.jar, therefore all classpathes
have to be adapted...

SUS->CMC:
If we decide to do so, would you be so kind to take this over as well?
Comment 11 caolanm 2006-02-07 11:46:23 UTC
cmc->sus: sure, I'd look into it, and be willing to do it. But I'd leave that as
a seperate followup task to this one here.
Comment 12 andreas.bille 2006-02-07 14:31:38 UTC
closed
Comment 13 andreas.bille 2006-02-07 15:23:06 UTC
accidentally closed
Comment 14 andreas.bille 2006-02-07 15:24:17 UTC
res
Comment 15 svante.schubert 2006-02-07 15:42:37 UTC
SUS->CMC:
Thank you!Marvelous!I will conact Martin Hollmichel to get a green light for the
follow-up patch and if so going to write you an enhancement task in one of my
CWS, so I will overtake the CWS handling.
Comment 16 andreas.bille 2006-03-11 15:53:10 UTC
Looks OK to me.
Comment 17 caolanm 2006-03-24 09:02:09 UTC
in m160