Issue 58410 - Importing MS-PP Slide using connector tool shows incorrect
Summary: Importing MS-PP Slide using connector tool shows incorrect
Status: CLOSED DUPLICATE of issue 13026
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.0
Hardware: All Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2005-11-25 02:14 UTC by wintera
Modified: 2005-12-15 14:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Curved connectors between figures (22.50 KB, application/vnd.ms-powerpoint)
2005-12-15 12:46 UTC, ecastro
no flags Details
Correct rendering of connectors in Presentacion.ppt with MS-Powerpoint (20.57 KB, application/pdf)
2005-12-15 12:47 UTC, ecastro
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description wintera 2005-11-25 02:14:00 UTC
Important from MS Power Point (Office2000) an org chart. The org chart used the
connector tool and standard text boxes. The lines drawn with the connector tool
showed incorrect and the lines needed to be redrawn. 

The connector tool in PP allows you on to connect to points and it autmatically
draws a line between them. 

While not a big thing, it seems that the important from MS (in my view a key
feature of OO) has still issues.

If you need more details let me know.

Axel
Comment 1 wolframgarten 2005-11-25 08:28:56 UTC
Reassigned.
Comment 2 christian.guenther 2005-12-01 16:16:36 UTC
I can't reproduce the bug.
What do you mean with 'Important from MS Power Point (Office2000) an org chart'
Should I load a PPT file which contains an org chart? or should I copy paste it, ...
could you attach the PPT document or the org chart to reproduce the bug?
Comment 3 christian.guenther 2005-12-06 15:15:43 UTC
I still can't reproduce the bug.
Please tell me what do you mean with the  connector tool and with the orgchart tool.
Please attach a (PPT) document where I can reproduce the bug.
Comment 4 ecastro 2005-12-15 12:46:32 UTC
Created attachment 32451 [details]
Curved connectors between figures
Comment 5 ecastro 2005-12-15 12:47:56 UTC
Created attachment 32452 [details]
Correct rendering of connectors  in Presentacion.ppt with MS-Powerpoint
Comment 6 ecastro 2005-12-15 12:58:54 UTC
Reproducible.
But the problem is confined to a subclass of connectors, in a particular
configuration. Curved connectors are calculated and rendered diferently in OOo
and  MS-Powerpoint, perhaps due to different implementation of Bezier
curves/splines.
See the example file above, and the PDF for the original rendering in MS-powerpoint.
The main difference arises when a curved connector touches the object with low
angle. The problem arises because in OOo the Bezier intermediate point
("handle") is positioned along the side of the object in this case, so de
connector is drawn parallel and too close to the actual object border. But the
conector line should start/end almost perpendicular to the object side at the
connecting node.   
Comment 7 christian.guenther 2005-12-15 14:09:36 UTC
I can't see any differents when I use the PPT org chart tool and import the
document.
The bug with the curved connectors is duplicate to issue 13026

*** This issue has been marked as a duplicate of 13026 ***
Comment 8 christian.guenther 2005-12-15 14:10:16 UTC
I close the issue as duplicate.