Issue 58443 - styles windows opens without focus
Summary: styles windows opens without focus
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.2
Hardware: PC All
: P3 Trivial with 2 votes (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 58444 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-11-25 14:49 UTC by tango
Modified: 2013-02-07 21:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tango 2005-11-25 14:49:21 UTC
It's may sound silly, and stupid, but affects productivity.

In earlier versions, like 1.1.4, when I was editing a text document and want to
change title style, I just pressed F11, the styles windows opened and selected
my desired style, all of this with keyboard.

Now, when trying 2.0, I tried to do the same, but when I pressed F11 style
window opened... WITHOUT FOCUS! I have to take my right hand over the keyboard
and move to my mouse, because my KDE, if I press Alt+Tab, change window, but
styles window never take focus. If I press Ctrl+Tab, change virtual desktop.

I know this may sound simple issue, but really affects productivity, and is
disturbing.

Hope this defect could be solved.
regards
Mauro Dionisi
Mendoza - Argentina
Comment 1 h.ilter 2005-11-25 16:36:40 UTC
Reassigned to ES
Comment 2 h.ilter 2005-11-25 16:37:35 UTC
*** Issue 58444 has been marked as a duplicate of this issue. ***
Comment 3 eric.savary 2005-11-27 16:41:31 UTC
Confirmed.

->SSA: your area?
Comment 4 stephan_schaefer 2005-12-02 15:19:18 UTC
ssa->pl: On Windows the focus moves into the floater (stylist or navigator) so I
assume that this is the wanted behaviour...
Comment 5 aahzpython 2005-12-10 03:19:34 UTC
I'm regressing to the earlier version of Ubuntu (5.04) because of this
bug.  I'm currently tech-editing a book, and this bug makes OOo unusable
(because the edits are written directly into the document and need to be
in a specific style).
Comment 6 aahzpython 2005-12-10 18:08:57 UTC
After some experimentation, I've figured out that this bug was introduced
in 1.1.5, presumably as part of the code that turned the style palette
into a sidebar.  It was difficult to make this determination, because it
turns out that my new motherboard isn't supported by older kernels, and
1.1.4 is not available for download anymore.

This is not acceptable.

Either keep older versions around or make x.y.N+1 versions ONLY bugfix
releases.
Comment 7 philipp.lohmann 2005-12-12 09:45:28 UTC
I'm not quite sure what you mean by "change turning the style palette into a
side bar". There was no such change. But "sidebar" sounds as if you simply
docked the stylist, if this is so, then you can simply undock it again by
pressing Ctrl and double clicking into an stylist area (that is somewhere it is
usually grey, not inside the listbox).
Comment 8 aahzpython 2005-12-12 14:47:43 UTC
Ah-ha!  You're correct about the docked vs undocked.  Nevertheless, this
bug was introduced in 1.1.5 -- I just checked.  A bit that may help:
when using F11 to activate the stylist, not only does the style window
not get focused, but the document window loses focus.  The doc window
losing focus only happens when the stylist is undocked.

Note that I still suspect that the docking behavior is related: 1.1.5
makes the stylist docked by default, which it was not in 1.1.4.  Also
note that when docked in 1.1.4, the stylist does not receive focus when
pressing F11.

Final note: checking against 2.0, I find that I cannot dock the stylist
at all.  (Doesn't bother me because I'd never want it docked, but that
may help you track down what happened.)
Comment 9 tango 2005-12-16 18:31:17 UTC
Hi,
After reading this comments, and seeing that this defect is not critical I
started looking for alternatives.
Once upon a time, 9 years ago I only used MS Word. As I can remember, to change
styles I could use Ctrl+Shift+1 (2,3,etc).
After 5' looking at Tools, Customize, Keyboard I founded that Ctrl+1, Ctrl+2 and
Ctrl+3 change paragraph's style to Heading 1, 2 and 3. I use until level 4, so I
changed Cltr+4 to Paragraph Styles -> Heading 4.

So, aahzpython, just like me, can continue editing with full productivity using
this Shortcuts. :-D

regards
Mauro Dionisi
Mendoza - Argentina
Comment 10 aahzpython 2005-12-17 05:10:37 UTC
Many thanks!  I still want this bug fixed, but this certainly is an
acceptable workaround.
Comment 11 stastnj1 2006-05-24 13:35:49 UTC
I found the same problem - and it is really distracting. I have problems with
my wrist due to RSI - so I want to avoid as much of using mouse as possible.
Thanks for the shortcuts, they are helpfull but I really look forward to have
the bug fixed :-)
Comment 12 cno 2007-04-28 20:50:37 UTC
Hi,
Stylist gets focus on opening (checked with 2.2 on XP and 2.0.3 on Debian)
So is fixed lately.
Set to closed, Fixed.
Comment 13 cno 2007-05-06 09:04:03 UTC
Found out that there is s difference between Stylist in docked and undocked status.
When docked, Stylist indeed doesn't get focus.
Checked with 2.2 on Debian and XP
Comment 14 cno 2007-05-06 09:07:43 UTC
change OS and version
Comment 15 philipp.lohmann 2009-01-06 12:48:37 UTC
this is more of a change request, because currently the stylist and navigator
pop up intentionally without focus (Window::Show called with SHOW_NOACTIVATE
flag). I guess the reason is that the state of the stylist and navigator is
persistent, so whenever you open a new document, it would would open with a
focused stylist or navigator - which is kind of not handy.
Comment 16 philipp.lohmann 2009-01-06 12:50:07 UTC
see also issue 93515 which makes Show with SHOW_NOACTIVATE more reliable on the
X11 platforms.
Comment 17 cno 2009-01-06 13:02:28 UTC
@pl:
your comment makes me think of issue 81467 "Opened Navigator, when docked, grabs
focus on starting new document".
Also seems related.
Comment 18 tango 2009-09-23 17:49:45 UTC
I've just tested this with: 

OOo 2.4 on Ubuntu 8.04.3.
Linux 2.6.24-24-server #1 SMP Sat Aug 22 00:59:57 UTC 2009 x86_64 GNU/Linux
OpenOffice.org 2.4.1
openoffice.org-core 1:2.4.1-1ubuntu2.1

Linux 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009 x86_64 GNU/Linux
OpenOffice.org 3.0.1
openoffice.org-core 1:3.0.1-9ubuntu3

When I press F11, styles window appears and focused. 
After pressing Alt+Tab, focus returns to Document window.
It's working!!!

I think that this behavior should be tested on more platforms in order to close
this issue.

thanks.
Comment 19 cno 2009-09-23 21:31:55 UTC
@ tango:
When I test on XP, with the Stylist *docked*, it still does not have the focus...
Are you sure you tried with a docked panel?