Issue 58466 - Imported pictures are set invisible due to corrupted frame style
Summary: Imported pictures are set invisible due to corrupted frame style
Status: ACCEPTED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-11-25 21:47 UTC by cseidel
Modified: 2017-05-20 11:15 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
bad document-template in which the defect occurs (27.37 KB, application/vnd.oasis.opendocument.text)
2005-11-25 21:49 UTC, cseidel
no flags Details
A test picture (41.29 KB, image/png)
2005-11-25 21:50 UTC, cseidel
no flags Details
Repaired document (27.58 KB, application/octet-stream)
2005-12-13 12:16 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cseidel 2005-11-25 21:47:33 UTC
While writing a document with many pictures, i experimented with the settings
for graphic and frame-templates. At some point, any new picture (jpg, wmf, png,
...) i imported to the document was set invisible. I tried drag&drop from
desktop and Menu insert->picture->from file (i use the german version- don't
know, if the names are correct).
The picture was imported and shown in the navigator and the tool-tip of this
entry shows "...invisible".
There is no chance to set the picture visible again, because a) you can't select
the picture or the anchor and b) the navigator-context-menu "...edit" ist
completely missing.

I added the bad document-template an a test-picture.

Do the following:
1. Open a new document from the template.
2. Try to import a picture (drag&drop or insert->picture)
3. The a look at the navigator. Graphic is grayed out and labeled "...invisible"
3. Try to select the picture in any way
now something strange:
4. Go to stylist, there is a template "grafik" (in german. Don't know, how it is
displayed in other versions, perhaps "graphic" ?)
5. Select "edit" from the context-menu, *don't change anything*, click "ok".
6. From now on, any picture can be imported normally.

Greetings from germany,
Carsten
Comment 1 cseidel 2005-11-25 21:49:31 UTC
Created attachment 31816 [details]
bad document-template in which the defect occurs
Comment 2 cseidel 2005-11-25 21:50:31 UTC
Created attachment 31817 [details]
A test picture
Comment 3 lars 2005-11-26 12:18:59 UTC
confirmed on Windows XP SP2 with OOo-dev 2.0.139
Comment 4 jack.warchold 2005-11-28 14:30:18 UTC
confirmed, but this seems to be a special problem with this template, because it 
does work in the default style.
i can see an embeded grafic if i delete the custom styles "vorformatiert" and "grafik" 
save the template and reload the new one.
you can still not import new ones but see this one.
lowered prio to P3
set a target OOo later

mru you should take a look on this
Comment 5 michael.ruess 2005-12-13 12:13:36 UTC
MRU->OS: the problem is, that the frame style "Graphics" has the property
"anchored to page". This is forbidden in OO Writer for frame styles (this is why
it is not offered in the Edit.Frame style dialog).
The wrong property was assigned to the style via "Update style" option in
"Styles and formatting" window.

MRU->cseidel: I will attach a "repaired" version of the template. Please do not
use the "update style" function with chnaged anchoring of a graphic or frame.
Comment 6 michael.ruess 2005-12-13 12:15:08 UTC
corrected some internal flags.
Comment 7 michael.ruess 2005-12-13 12:16:16 UTC
Created attachment 32341 [details]
Repaired document
Comment 8 Mathias_Bauer 2006-01-23 12:35:32 UTC
We will not finish this in the 2.0.2 time frame -> retargetted to 2.0.3
Comment 9 Oliver Specht 2006-05-18 12:44:34 UTC
Target changed to 2.x
Comment 10 Martin Hollmichel 2007-09-10 13:36:09 UTC
move target to 3.x according http://wiki.services.openoffice.org/wiki/Target_3x
Comment 11 Marcus 2017-05-20 11:15:19 UTC
Reset assigne to the default "issues@openoffice.apache.org".