Issue 58747 - In an expression such as 3x, the x is not recogised as a variable
Summary: In an expression such as 3x, the x is not recogised as a variable
Status: CLOSED DUPLICATE of issue 45689
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-12-01 17:56 UTC by andyl
Modified: 2005-12-02 13:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description andyl 2005-12-01 17:56:41 UTC
This seems to be a regression from OOo 1.1.x.

In OOo 1.1.x, if an expression such as x^2+3x+5 is entered into the formula
editor (with the usual font settings: italic for variables, non-italic for
numbers), both "x"s are rendered in italic (correctly).

In OOo 2.0, if an expression such as x^2+3x+5 is entered into the formula editor
(with the usual font settings: Italic for variables, non-italic for numbers),
the first "x" is rendered in italic (correctly) but the second is not.  It seems
that the exprssion 3x is treated as a number rather than being recognised as a
number followed by a variable. A workaround is to enter a space between the 3
and the x ie x^2+3 x+5, but this is irritating to remember every time. Is there
a reason why this worked corrctly in 1.1.x but not in 2.0?
Comment 1 Regina Henschel 2005-12-01 18:29:50 UTC
Error as described in OOo-dev m139 too.

It might be the same reason as in issue 45689, although it is submitted for
variable here.
Comment 2 jack.warchold 2005-12-02 13:59:11 UTC
set to duplicate.

for me this is a duplicate of issue 45689

*** This issue has been marked as a duplicate of 45689 ***
Comment 3 jack.warchold 2005-12-02 13:59:39 UTC
duplicate -> closed