Issue 59101 - Randomly checked checkbox in PDF export
Summary: Randomly checked checkbox in PDF export
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.0
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-12-08 23:34 UTC by arnechaa
Modified: 2005-12-09 14:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Word template (414.00 KB, application/msword)
2005-12-08 23:38 UTC, arnechaa
no flags Details
Word template saved in OO doc format. Note paragraph nr 26 which has no check boxes checed (42.41 KB, application/vnd.sun.xml.writer)
2005-12-08 23:41 UTC, arnechaa
no flags Details
PDF export og OO-doc. Note paragraph 26 which now has a check in last check box. (240.37 KB, application/pdf)
2005-12-08 23:43 UTC, arnechaa
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description arnechaa 2005-12-08 23:34:42 UTC
Hi!

I have a Word form. When this form is exported to PDF in OO 2.0 Writer some 
check boxes seem to be checked at random.

This form also shows a number of formating problems when read in OO Writer.

I can send you the form.
Comment 1 arnechaa 2005-12-08 23:38:37 UTC
Created attachment 32230 [details]
Word template
Comment 2 arnechaa 2005-12-08 23:41:10 UTC
Created attachment 32231 [details]
Word template saved in OO doc format. Note paragraph nr 26 which has no check boxes checed
Comment 3 arnechaa 2005-12-08 23:43:04 UTC
Created attachment 32232 [details]
PDF export og OO-doc. Note paragraph 26 which now has a check in last check box.
Comment 4 arnechaa 2005-12-08 23:51:47 UTC
I consider this a very bad bug since incorrectly set check boxes may have 
catastrophic consequences for the user depending on the nature of the form. 
The formating problems may also result in rejected forms. The priority must be 
set accordingly (I forgot to set it).
Comment 5 michael.ruess 2005-12-09 07:33:44 UTC
Reassigned to HI.
Comment 6 aziem 2005-12-09 14:20:21 UTC
Using .odt attachment, I tested on three builds which imply problem has been fixed.
- Linux RPMs OOo 1.1.5: no boxes check
- Linux RPMs OOo 2.0.0: same boxed check
- Linux RPMs OOo 2.0.1rc1: no boxes check


If you see this bug after 2.0.0, please reopen this issue.
Comment 7 aziem 2005-12-09 14:20:49 UTC
BTW, 2.0.1 release candidate is available from http://download.openoffice.org