Issue 59248 - Arrow keys not active when switching to Slide Sorter View
Summary: Arrow keys not active when switching to Slide Sorter View
Status: ACCEPTED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.1
Hardware: All Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-12-12 15:32 UTC by ftack
Modified: 2017-05-20 11:09 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ftack 2005-12-12 15:32:21 UTC
Steps to reproduce the issue

* Open an new Impress document
* Create a few empty slides using Insert - Slide
* Click the "slide sorter" tab
* Arrow keys do not work. While Ctrl+space does allow to select/deselect slide
1, you cannot use the arrow keys to move the selection

Remedies: 
* press tab once: now the arrow keys work
or
* switch away and back to Impress: now the arrow keys work

This is a minor issue and probably a P4 of P5, but care should go into such
details of the user interface as well.
Comment 1 lars 2005-12-12 18:25:20 UTC
confirmed on Windows XP Pro SP2 with OOo 2.0.1 RC4
Comment 2 wolframgarten 2005-12-13 08:13:52 UTC
Reproducible. Reassigned.
Comment 3 shivjin 2006-01-24 23:11:16 UTC
I was also able to reproduce the defect by following the steps provided.

This defect was reproducible with the following:

	Windows 2000 Professional and Open Office 2.0
	Linux and Open Office 2.0

In addition to reproducing the defect I ran some follow up testing:

Test 1 – Selecting slide sort option from the menu bar.  
I found that when you select the slide sort option from the menu bar the arrow
keys work.  Here are the steps to reproduce this test case:

1) Select file-> new presentation
2) Select empty presentation and press create
3) Select insert slide three times so you have three slides
4) Select view-> Slide sorter
5) Test the arrow keys (they should be working)

Test 2- Selecting the slide sort tab button first and then selecting the slide
sorter from the menu bar.
If you select the slide sorter from the menu after you are in the slide sorter
view (from slide sorter tab) then the arrow keys will still not work.  You have
to go into a different view and then go into the slide sorter view from the menu
bar in order for the arrow keys to work.

This defect may be an inconvenience to users who are not using a mouse and rely
only on the keyboard.  Its importance is not too high since there is a way
around this problem (using the menu bar) as stated above or by using the tab key
or by swithcing away and back to impress as mentioned in the previous comments.
Comment 4 groucho266 2006-01-25 09:20:25 UTC
This is not exactly a bug.  What we have here is a not so well designed mixture
of two concepts.  
Firstly there is the selection.  By default the currently visible slide is
selected.  Pressing PageUp or PageDown makes the next or previous slide visible
and selects it in the slide sorter.
Secondly there is the focus.  The dotted focus frame is not shown by default. 
You have to press Tab to make it visible.  After that the focus can be moved
with the Arrow keys.  Clicking on the slide sorter does not make the focus frame
visible (as is the case in other controls as well).

One solution to this problem is to abandon an explicit focus rectangle and merge
some of its behaviour into the selection.
Comment 5 ftack 2009-02-09 16:48:40 UTC
I cannot anymore reproduce this issue on Ubuntu Hardy 8.04 (OOo 2.4.1). Perhaps
this issue can be closed as WORKSFORME.
Comment 6 ftack 2010-08-18 12:43:25 UTC
After seven years, this issue still needs some attention. There is inconsistent
and confusing behaviour.

* I have three slides.Currently on the second one.
* Click "Slide sorter", first arrow press has the focus appear, second arrow has
the focus move. Not particular intuitive behaviour.
* Thisr arrow press has the focus disappear. No way to get it back with the
arrow keys.

* Currently on the third slide
* Click "Slide sorter": no focus appears at all. Switching away or pressing tab
makes it appear.

It is also possible to "loose" the focus in the "Slides" pane at the left of the
screen. Go to the first or to the last slide with the up or don arrow, then
press the left arrow (when on the first slide) or the right arrow (when on the
bottom slide).
Comment 7 Marcus 2017-05-20 11:09:00 UTC
Reset assigne to the default "issues@openoffice.apache.org".