Issue 59345 - RTF import does not import graphics and text frames, sometimes crashes
Summary: RTF import does not import graphics and text frames, sometimes crashes
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 680m142
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 59280 60139 60147 60830 61718 (view as issue list)
Depends on:
Blocks: 52366 56651
  Show dependency tree
 
Reported: 2005-12-14 13:17 UTC by andreas.martens
Modified: 2013-08-07 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bugdoc (2.93 MB, text/rtf)
2005-12-14 13:51 UTC, andreas.martens
no flags Details
Smaller bugdoc (6.02 KB, text/rtf)
2005-12-14 13:53 UTC, andreas.martens
no flags Details
Screenshot "C1.PNG" (59.56 KB, image/png)
2006-09-18 20:48 UTC, tmjura
no flags Details
Screenshot "C2.PNG" (245.66 KB, image/png)
2006-09-18 20:49 UTC, tmjura
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description andreas.martens 2005-12-14 13:17:57 UTC
Open a simple doc like the attachment which contains a graphic and a text frame.
If you are lucky, your office doesn't crash but the graphic is lost. The content
of the text frame is inserted into the "normal" text flow, not inside a frame.
Comment 1 andreas.martens 2005-12-14 13:51:51 UTC
Created attachment 32388 [details]
Bugdoc
Comment 2 andreas.martens 2005-12-14 13:53:33 UTC
Created attachment 32389 [details]
Smaller bugdoc
Comment 3 andreas.martens 2005-12-14 15:34:24 UTC
Fixed in 
sw/source/filter/rtf/rtffly.cxx 1.21.28.1
sw/source/core/layout/layact.cxx 1.54.68.1
Comment 4 andreas.martens 2005-12-22 15:36:29 UTC
AMA->MRU: Checked in internal installation set of cws swqbf48 - please verify.

re-open issue and reassign to mru@openoffice.org
Comment 5 andreas.martens 2005-12-22 15:37:30 UTC
reassign to mru@openoffice.org
Comment 6 andreas.martens 2005-12-22 15:38:15 UTC
reset resolution to FIXED
Comment 7 michael.ruess 2006-01-09 08:35:51 UTC
*** Issue 60147 has been marked as a duplicate of this issue. ***
Comment 8 michael.ruess 2006-01-09 08:59:34 UTC
*** Issue 60139 has been marked as a duplicate of this issue. ***
Comment 9 Oliver-Rainer Wittmann 2006-01-13 11:17:54 UTC
*** Issue 59280 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2006-01-13 15:08:57 UTC
*** Issue 60139 has been marked as a duplicate of this issue. ***
Comment 11 michael.ruess 2006-01-18 13:02:21 UTC
Verified fix in CWS swqbf48.
Comment 12 michael.ruess 2006-01-19 16:25:55 UTC
*** Issue 60830 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2006-02-07 08:44:03 UTC
*** Issue 61718 has been marked as a duplicate of this issue. ***
Comment 14 michael.ruess 2006-02-07 08:51:20 UTC
Checked fix in 680m153.
Comment 15 tmjura 2006-09-18 20:46:25 UTC
I opened that smaller version of "hello.rtf" in OpenOffice 2.0.3.

I have to say that it looked totally different in OpenOffice 2.0.3 than in Word 
2002.

1. There is two pictures visible, i.e. the picture is dublicated
2. The text in text frame is separated to two lines.
3. The text "Hello, world" is separated to two lines.
==> See screenshots "C1.PNG" and "C2.png"

This was repeated with smaller and bigger "hello.rtf".

SO.
- This might be a duplicate of another issue.
- Or this issue has to be reopened.


To be precise what I used
- WIN XP Professional version 2002 SP 2 + updates
- OpenOffice 2.0.3 OOC680_m7 Build 1 (Tue Jun 29 16;19;13 CEDT 2006) (Finnish 
version)
- OpenOffice Finnish proofreader: oo2-soikko-Windows-1.1.1.exe
- Word 2002 (10.6802.6735) SP 3 (English version)
Comment 16 tmjura 2006-09-18 20:48:22 UTC
Created attachment 39230 [details]
Screenshot "C1.PNG"
Comment 17 tmjura 2006-09-18 20:49:14 UTC
Created attachment 39231 [details]
Screenshot "C2.PNG"
Comment 18 michael.ruess 2006-09-19 06:59:22 UTC
MRU->tmjura: please file a new issue as long as this is a similar problem. It is
not good to reopen already fixed issues, because handling of this is VERY
inconvenient.