Issue 59596 - Hyphenated words in pt-BR
Summary: Hyphenated words in pt-BR
Status: CLOSED DUPLICATE of issue 64400
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: issues@lingucomponent
QA Contact: issues@lingucomponent
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-12-20 14:22 UTC by Roberto Salomon
Modified: 2013-02-24 20:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Roberto Salomon 2005-12-20 14:22:15 UTC
The following problem happens in pt-BR. Certain verb conjugations require the
verb to be modified and the object to be shown as a suffix preceded by a hyphen.
An example is the verb "abrir" (to open).

The sentence "I tried to open it" is rendered in pt_BR as "Tentei abrí-lo" or
"Tentei abrí-la" according to gender. The verb "abrir" is changed to "abrí" and
the object to "-lo". Spellcheck does not recognize the new form and marks "abrí"
as mispelled while ignoring "-lo" as being part of the word.

Although a quick hack would be to include "abrí" in the spelling dictionary,
"abrí" without the object "-lo" would be mispelled.

Is there an ispell rule that is used in other languages to handle this or a code
change is required?
Comment 1 lohmaier 2007-02-03 01:26:38 UTC
duplicate.

*** This issue has been marked as a duplicate of 64400 ***
Comment 2 lohmaier 2007-02-03 01:27:43 UTC
closing duplicate.