Issue 59651 - PDF/A (ISO 19005-1) support would be helpful
Summary: PDF/A (ISO 19005-1) support would be helpful
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial with 13 votes (vote)
Target Milestone: OOo 2.4
Assignee: jack.warchold
QA Contact: issues@gsl
URL:
Keywords:
: 66072 70170 (view as issue list)
Depends on: 82069
Blocks:
  Show dependency tree
 
Reported: 2005-12-21 18:30 UTC by papen
Modified: 2009-07-20 14:53 UTC (History)
8 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
proposed specification update (40.12 KB, application/vnd.oasis.opendocument.text)
2007-09-26 20:18 UTC, Giuseppe Castagno (aka beppec56)
no flags Details
Version of PDFExportDialog.odt specification addendum the CWS beppec56pdfa1b is based on (64.95 KB, application/vnd.oasis.opendocument.text)
2007-11-06 13:45 UTC, Giuseppe Castagno (aka beppec56)
no flags Details
Blank PDF/A export from 2.4 RC6 - check failed (7.55 KB, application/pdf)
2008-03-21 10:17 UTC, stef4o
no flags Details
ODT file not validating against pdfaPilot 1.0.047 after PDF conversion with OOo 2.4.0 (19.07 KB, application/vnd.oasis.opendocument.text)
2008-04-10 10:36 UTC, fjuillet
no flags Details
Generated PDF not validating agaisnt pdfaPilot 1.0.047 (208.41 KB, application/pdf)
2008-04-10 10:38 UTC, fjuillet
no flags Details
pdfaPilot 1.0.047 report for odt_simple.pdf (20.06 KB, text/html)
2008-04-10 10:39 UTC, fjuillet
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description papen 2005-12-21 18:30:57 UTC
As we all know, PDF is a document standard provided by Adobe. However, there are
several versions of PDF and options in PDF which might compromise its quality as
an archive. For that reason, ISO 19005-1 (PDF itself is NOT an ISO standard) has
been created and guarantees that the document will still be readable in the
future. This is important for documents such as PhD thesis, scientific papers etc.

The official abstract is "ISO 19005-1:2005 specifies how to use the Portable
Document Format (PDF) 1.4 for long-term preservation of electronic documents. It
is applicable to documents containing combinations of character, raster and
vector data."

Key issues of PDF/A are that fonts have to be embedded, audio, video and
JavaScript are not allowed and PDF 1.4 has to be used.

It should be possible to ensure that every PDF document produced by OOo complies
to ISO 19005-1. Otherwise the user should be able to chose PDF/A compliance by a
checkbox.

Remark: there is another ISO standard for PDF: ISO 15930 (PDF/X) for printing
purposes. I don't see the need to support that standard, but other users may
open an issue for it.
Comment 1 stephan_schaefer 2005-12-22 08:20:23 UTC
ssa->pl: I think this is a quite useful (and probably easy) enhancement and
would fit perfectly to our PDF story. Please follow up on this.
Comment 2 philipp.lohmann 2005-12-22 09:53:20 UTC
If those were the only issues, we were already there; however as far as i know
there are certain PDF tags to be supported for PDF/A. I'll have a look.
Comment 3 philipp.lohmann 2006-06-15 16:22:35 UTC
target
Comment 4 Giuseppe Castagno (aka beppec56) 2006-07-25 11:33:04 UTC
CC myself
Comment 5 Giuseppe Castagno (aka beppec56) 2006-07-25 12:21:55 UTC
-> I noticed that issue 66072 seems referring to this same topic, but it is
filed with different headers and I don't know how that can be managed without
loosing the community votes there.

If the implementation of this feature in sight ?
Comment 6 philipp.lohmann 2006-07-25 13:49:30 UTC
*** Issue 66072 has been marked as a duplicate of this issue. ***
Comment 7 andreschnabel 2006-10-09 22:18:42 UTC
*** Issue 70170 has been marked as a duplicate of this issue. ***
Comment 8 ymulleneers 2007-02-14 12:00:44 UTC
See www.belgif.be, PDF may soon be unallowed but PDF/A is studied
Comment 9 Giuseppe Castagno (aka beppec56) 2007-07-05 09:36:42 UTC
I'll start implementing the issue
Comment 10 Giuseppe Castagno (aka beppec56) 2007-07-05 09:50:17 UTC
accepted, started, I set target on former change.

=-> pl. I'll start writing the OOo code spec as we agreed.
Comment 11 mbayer 2007-07-30 22:35:10 UTC
My vote for an option to switch OOo's PDF export into PDF/A mode (on the PDF
Options dialogue, the one you get via File -> Export as PDF) - or make it a
separate item in File -> Export... -> File Format.
Comment 12 eberlein 2007-08-14 11:40:17 UTC
+1

@beppec56:
Will digital signatures be supported too in your implementation (PDF/A - 2 IIRC)?
Comment 13 Giuseppe Castagno (aka beppec56) 2007-08-15 10:39:43 UTC
@eberlein: nope, the signature of PDF is requested in issue 47895. You may want
to CC in there to stay tuned.


Comment 14 stef4o 2007-08-17 15:25:32 UTC
@beppec56

My votes (+2) are for a "PDF/A - 1a" implementation for Long Term Archival
purpose: this is the most important requirement for PA, i think.
As a half-step it could be useful a "PDF/A - 1b" level implementation, but the
former is the goal. So the user should be able to choose 1a or 1b compliance by
selecting a radio button.

Stefano
Comment 15 Giuseppe Castagno (aka beppec56) 2007-09-26 20:17:05 UTC
@mmp: I added you to CC list because I'm going to attach a specification update
to PDFExportDialog.odt. I'm working on an update for issue 56629 as well, Would
you like like to have both in a single shot?

@stef4o: it will be PDF/A-1a.
Comment 16 Giuseppe Castagno (aka beppec56) 2007-09-26 20:18:20 UTC
Created attachment 48528 [details]
proposed specification update
Comment 17 ymulleneers 2007-09-27 16:00:52 UTC
Thanks for the document above.  

I have a comment thought : The new “PDF/A-1a†checkbox may be a new combo list
box "PDF standart" (a list with two choices : "PDF 1.4" and "ISO 19005-1:2000").
 Of course, selecting one or the other would have the same effect as selecting
or unselecting the new “PDF/A-1a†checkbox.

I think (but I'm not a specialist of programming) that will not harden the
hacking but may simplify the work if an other standard had to be used in a
possible future.
Comment 18 philipp.lohmann 2007-09-27 17:01:47 UTC
Good idea. Though we never had a user interface for it, PDFWriter has long since
been able to produce PDF 1.2 to 1.4; I wouldn't add 1.2 and 1.3 here, but in
future we may want to add e.g. 1.5's object streams to achieve better overall
compression which would add a PDF-1.5 entry. 
Comment 19 philipp.lohmann 2007-09-28 10:54:06 UTC
Concerning the last part of the document (QA considerations); a suitable
collection of fonts should contain at least fonts for Times, Helvetica, Courier
and a Symbol font. If Symbol is not available a substitution with OpenSymbol
should work, although the result will contain different glyphs.
Comment 20 Giuseppe Castagno (aka beppec56) 2007-10-04 12:48:02 UTC
@pl: should I change the PDF/A-1 checkbox to a combo list as you suggested in
desc19 above?
Internally the code already works that way, only the UI needs change.
I didn't use the combo because I thought the tabs was crowed.
I'd rather wait for UX suggestion here...

I'll add a few lines to Q&A area as you noted in desc20.
Comment 21 Giuseppe Castagno (aka beppec56) 2007-11-06 13:45:22 UTC
Created attachment 49458 [details]
Version of PDFExportDialog.odt specification addendum the CWS beppec56pdfa1b is based on
Comment 22 Giuseppe Castagno (aka beppec56) 2007-11-06 13:54:42 UTC
ready for QA
Comment 23 Giuseppe Castagno (aka beppec56) 2007-11-06 13:57:44 UTC
-> jw, please verify in CWS beppec56pfda1b, specification addedum in desc22 above.
Comment 24 philipp.lohmann 2007-11-06 14:40:53 UTC
setting to fixed
Comment 25 jack.warchold 2007-11-09 13:15:54 UTC
verifaction on Adobe is ok, but i found another tool on the following site http://
www.datalogics.com/products/utils/callaspdfA-onlinedemo.asp where the 
validation failed. the error is "Colors are not defined as neutral, and therefore do not 
always appear the same." 

this bug will be integrated in the cws beppec56pdflinks and this cws will be 
deleted.
Comment 26 jack.warchold 2007-11-13 15:08:33 UTC
seen good in the cws beppec56pdflinks

set to verified
Comment 27 stef4o 2008-03-21 09:44:35 UTC
I tested the feature using OpenOffice.org 2.4 Release Candidate 6 (build
OOH680_m12) under Win XP against a blank document and against the OpenDocument
v1.0 (Second Edition) specification as a reference document.

As suggested from the article at
(http://www.oooninja.com/2008/01/generating-pdfa-for-long-term-archiving.html),
I submitted both documents to the pdfaPilot PDF/A Online Demo for validation
(http://www.datalogics.com/products/utils/callaspdfA-onlinedemo.asp), and it
failed as PDF/A-1a and PDF/A-1b.

I also submitted the two documents to DROID
(http://droid.sourceforge.net/wiki/index.php/Download) that recognized the PDF
1.4 format, not the expected PDF/A.

What was wrong? Should I re-open this issue or a new one relative to 2.4RC6?
Thanks in advance for helping.
Comment 28 Giuseppe Castagno (aka beppec56) 2008-03-21 10:14:20 UTC
@stef4o: can you attach the resulting PDF documents, the ones not passing the
PDF/A tests? I'd like to have a look.
Comment 29 stef4o 2008-03-21 10:17:44 UTC
Created attachment 52235 [details]
Blank PDF/A export from 2.4 RC6 - check failed
Comment 30 Giuseppe Castagno (aka beppec56) 2008-03-21 10:19:49 UTC
@stef4o: I just generated the OpenDocument 1.0 ed.2 PDF/A, it's about 11 Mb, so
please attach only the smaller of the two, if you can.
Comment 31 Giuseppe Castagno (aka beppec56) 2008-03-21 10:26:38 UTC
@stef4o: I checked the file you attached on #desc30 above against:

http://www.datalogics.com/products/utils/callaspdfA-onlinedemo.asp

and it passed the test. I didn't test it with the other tool you mentioned in
#desc28 above.

In any case if you feel there is some problem please feel free to open another
issue.
Comment 32 stef4o 2008-03-21 10:29:50 UTC
Im' going to add another couple of docs, as i noticed the size of reference
document ...
Comment 33 stef4o 2008-03-21 11:30:42 UTC
My own excuses: online validator really works! I found failures were caused by
cookies disabled on browser settings. 

Maybe droid project is not mature enough.
Comment 34 fjuillet 2008-04-10 10:27:17 UTC
I'm conducting conversion tests to PDF/A from office documents with
OpenOffice.org 2.4.0. I got positive results with PDF/A-1a validations with
Adobe Acrobat 8 (pre-flight function) and Callas pdfaPilot 1.0.037 and its
online version you used for your own testing.

However, I encountered problems with the newest version of Callas pdfaPilot
1.0.047 (eval version -
http://www.callassoftware.com/callas/doku.php/en:products:pdfapilotserver),
which indicates non-conformance due to transparency problems (report below).

I used a set of about 30 files with different complexities, and the error
reported was the same for each files, except for the number of occurrences.

I include in attachment an odt file producing the problem, with the
corresponding generated PDF, and the report from pdfaPilot.

Analysis report : 

 callas pdfaPilot Report  
 PDF/A-1a validation failed
ods_simple.pdf 
Title: META::Titre
Author: META::Auteur
Pages: 6 - 595.0x842.0 pt 
Size: 72.7 KBytes - PDF-Version: 1.4
Origin: Calc
Created with: OpenOffice.org 2.4
Last Change: 

No additional checks
Report created: 10/04/2008 11:10
pdfaPilot-Version: 1.0.047  

 Unfixable Problems  Details

 Transparency invalid     

 The visualization of transparent objects is not clearly specified.  

 Details
   
 A group of page objects appears partially transparent (1151 matches on 6 pages)   
  -  Filled areas RGB (2 matches)   
  -  Lines RGB 0.1 - 0.6 pt (13 matches)   
  -  Text Arial-BoldItalicMT 10.0 pt TrueType embedded (as a subset) (17 matches)   
  -  Text Arial-BoldMT 48.0 pt TrueType embedded (as a subset) (1 match)   
  -  Text ArialMT 9.0 - 20.0 pt TrueType embedded (as a subset) (1118 matches)  
Comment 35 fjuillet 2008-04-10 10:36:39 UTC
Created attachment 52713 [details]
ODT file not validating against pdfaPilot 1.0.047 after PDF conversion with OOo 2.4.0
Comment 36 fjuillet 2008-04-10 10:38:25 UTC
Created attachment 52714 [details]
Generated PDF not validating agaisnt pdfaPilot 1.0.047
Comment 37 fjuillet 2008-04-10 10:39:39 UTC
Created attachment 52715 [details]
pdfaPilot 1.0.047 report for odt_simple.pdf
Comment 38 Giuseppe Castagno (aka beppec56) 2008-04-10 10:50:22 UTC
@fjuillet.

Could you open a new issue for this?
It would ease the investigation into the problem.

Assign it to gsl component, code subcomponent.

Thanks.
Comment 39 fjuillet 2008-04-10 11:08:50 UTC
@beppec56

Done : the file issue is 88123 

Thanks
Comment 40 windl 2008-04-14 07:22:07 UTC
PDF/A export in OpenOffice 2.4.0 does not pass the PDF/A-1b conformance check of
Adobe Acrobat 7's Preflight. The error message is (German): "PDF/A Eintrag nicht
vorhanden" ("PDF/A entry not present").
If needed I can provide the sample file from OpenOffice, as well as a conforming
PDF/A document produced by Adobe Acrobat 7.
Comment 41 Giuseppe Castagno (aka beppec56) 2008-04-14 07:56:52 UTC
@windl.
If I where you, I'd check the PDF/A-1 checkbox status on PDF export dialog box.

If the problem's still there, then, as I said in #desc39 above, can you open a
new issue? Component gsl, subcomponent code.

Thanks.
Comment 42 windl 2008-04-17 06:57:11 UTC
The comment "If I where you, I'd check the PDF/A-1 checkbox status on PDF export
dialog box." in the weak interpretation seems to say that I checked a non-PDF/A
for PDF/A compatibility, which is, of course, not true.

I did not open a new issue, because this one is about implementing PDF/A, and it
seems the implementation is incomplete at least. Reopening the issue seems right
to me.
Comment 43 Giuseppe Castagno (aka beppec56) 2008-04-17 12:31:01 UTC
@windl

> I did not open a new issue, because this one is about implementing PDF/A,
> and it seems the implementation is incomplete at least. Reopening the
> issue seems right to me.

I suggested to open a new issue simply because it is better and more quickly
investigated.
Comment 44 thorsten.ziehm 2009-07-20 14:53:51 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues