Issue 59974 - [gtk-vclplugin] Ctrl-Shift-U Unicode Input Method should apply on releasing Ctrl-Shift (like in "real" GTK apps)
Summary: [gtk-vclplugin] Ctrl-Shift-U Unicode Input Method should apply on releasing C...
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0
Hardware: All Unix, all
: P4 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: stefan.baltzer
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-01-03 02:07 UTC by ikonst
Modified: 2017-05-20 10:24 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ikonst 2006-01-03 02:07:55 UTC
When using the Ctrl-Shift Unicode Input Method (holding Ctrl-Shift and entering
the hex codepoint of the Unicode character you wish to insert), the character
should be added upon releasing Ctrl-Shift.

Instead, right now it's only added upon entering the following character.
Comment 1 thorsten.martens 2006-01-05 13:41:01 UTC
TM->SBA: please have a look. Thanks !
Comment 2 kpalagin 2007-04-10 19:05:54 UTC
Can't get Ctrl-Shift code to do anything.
Resolving as invalid.
Comment 3 kpalagin 2007-04-10 19:16:49 UTC
And closing.
Comment 4 ikonst 2007-04-10 20:07:27 UTC
Ok, the input method was changed (in gtk2 and subsequentially in OO.org): now,
after holding Ctrl-Shift, you should press "U" before entering the hex codepoint.

However, the issue still holds because you need to press Enter while holding
Ctrl-Shift for the codepoint to be accepted, whereas in Gtk2 you simply need to
release Ctrl-Shift.
Comment 5 kpalagin 2007-04-11 12:24:55 UTC
ikonst,
still can't get it working (with OO 2.2 on either WinXP or Suse 10.2 KDE)
Comment 6 ikonst 2007-04-12 08:16:14 UTC
kpalagin, does this input method work for you in regular Gtk2 applications (e.g.
Gedit)?
Comment 7 kpalagin 2007-04-12 19:03:41 UTC
No, I can't get it to work in Gedit either.
Comment 8 ikonst 2007-04-12 19:39:28 UTC
Right-click the input field in Gedit and see what input method you have set. For
me, it only works with the Default one.
Comment 9 kpalagin 2007-04-12 20:10:27 UTC
ikonst,
switching to default IME works (sort of - I get rectangles with 4 small 
circles inside) in Gedit.
Any idea how to make this work in OO?
Comment 10 ikonst 2007-04-13 00:15:35 UTC
If you enter a Unicode codepoint which doesn't have a symbol in your font, you'd
get the square with the Unicode value instead. Try ctrl-shift-u-61 to get the
letter 'a'.

To see what input method your applications will be using by default, see the
GTKDEFAULTIMMODULE environment variable.
Comment 11 lohmaier 2009-03-28 00:13:51 UTC
invalid, nothing OOo can do since as you already noticed, this is the gtk input
method, a feature from GTK, not from OOo
And the way it works is that you press enter to confirm your choice.
There are low codepoints like U+21 (!) or high codepoints like U+322B (㈫)
Entering those while still holding ctrl+shift would be very tedious, so IMHO it
is good and intended behaviour to be able to confirm with <enter>.
(don't hold shift+ctrl after pressing the "u" to enter the input method, just
press <ctr>+<shift>+u, release all keys, enter the codepoint and press <enter>)

While I can confirm that holding ctrl+shift while entering the codepoints and
releasing when done doesn't work like in real GTK-apps (it cancels the input
completely, nothing is entered, nothing is added to undo buffer), I don't think
this is a high-prio issue (since using enter works as expected and IMHO is the
more comfortable method.

Correcting flags, cannot be OS ALL, since GTK-feature and as Windows/Mac
versions don't use GTK....), lowering prio (more or less cosmetical)

##############################
###### summary/testcase ######
##############################
Assumptions: You're using OOo with the gtk-vclplugin and your input method is
set to the GTK-input method
Works:
* <ctrl>+<shift>+u 
* release all keys 
* enter unicode-hexvalue
* press <enter>
Works:
* <ctrl>+<shift>+u
* hold <ctrl>+<shift>, release u
* enter unicode-hexvalue
* press <enter>
Doesn't work, but works in real GTK-widgets/applications
* <ctrl>+<shift>+u
* hold <ctrl>+<shift>, release u
* enter unicode-hexvalue
* release <ctrl>+<shift>
Comment 12 stefan.baltzer 2009-06-13 23:04:00 UTC
Thx for the evaluation, cloph.
Set to invalid.
Comment 13 stefan.baltzer 2009-06-13 23:04:44 UTC
closed.
Comment 14 ccheney 2009-06-15 20:19:01 UTC
sba, cloph first noted 'invalid' and then went on to explain that it is actually
a bug in OOo.

"While I can confirm that holding ctrl+shift while entering the codepoints and
releasing when done doesn't work like in real GTK-apps (it cancels the input
completely, nothing is entered, nothing is added to undo buffer), I don't think
this is a high-prio issue (since using enter works as expected and IMHO is the
more comfortable method."

Reopening, no this is not a high priority issue as he said but it is a REAL BUG
in OOo itself. And it does make OOo appear less polished and less consistent on
the Linux desktop.
Comment 15 stefan.baltzer 2009-12-01 11:21:16 UTC
SBA->ccheney: You write "...it does make OOo appear less polished and less
consistent..." - Well, this is an attribute that matches to all open issues in
OOo... :-) Make developers rain from the sky and all remaining issues (10.000 or
 20.000 still to go?) will get fixed and the office will finally be free of
issues, polished, perfect and... DEAD. :-).

SBA->PL: Please have a look, thx.
Comment 16 philipp.lohmann 2010-04-22 18:43:13 UTC
fixed in CWS vcl111
Comment 17 philipp.lohmann 2010-05-21 12:15:55 UTC
please verify in CWS vcl111
Comment 18 stefan.baltzer 2010-06-09 13:08:06 UTC
Verified in CWS vcl111.