Issue 60067 - change of diagram background color during copy and paste
Summary: change of diagram background color during copy and paste
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.1
Hardware: PC Windows 2000
: P4 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0.4
Assignee: kla
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-01-05 14:11 UTC by timi_openoffice
Modified: 2006-11-27 09:32 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
File with the diagram (15.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2006-01-05 14:15 UTC, timi_openoffice
no flags Details
diagram copied to a text document (12.11 KB, application/vnd.oasis.opendocument.text)
2006-01-05 14:15 UTC, timi_openoffice
no flags Details
disired source document (27.50 KB, application/vnd.ms-excel)
2006-01-13 20:31 UTC, timi_openoffice
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description timi_openoffice 2006-01-05 14:11:38 UTC
When putting the diagramm from test.ods to a new text document via copy and
paste, then the color of the background (from up to down clear gray to dark
gray) changes  to black to white (test2.odt).

The .ods is an import from an .xls-document.

This behavior I could reproduce an OOo 2.0.1 / Windows 2000 and on OOo
1.9.125.1.2 (SuSE build coming with SuSE 10.0).
Comment 1 timi_openoffice 2006-01-05 14:15:00 UTC
Created attachment 32924 [details]
File with the diagram
Comment 2 timi_openoffice 2006-01-05 14:15:47 UTC
Created attachment 32925 [details]
diagram copied to a text document
Comment 3 lars 2006-01-05 17:56:43 UTC
confirmed on Windows XP Pro SP2 with OOo 2.0.1
Comment 4 thorsten.martens 2006-01-11 11:05:04 UTC
TM->SBA: Please have a look. 
Comment 5 stefan.baltzer 2006-01-12 10:43:41 UTC
SBA: This happens even with copy-paste within the same (Calc) document.
Reassigned to KLA.
Comment 6 bjoern.milcke 2006-01-12 15:25:52 UTC
The copied chart is correct, it is the same as the original. What is wrong is
the replacement-image. In OOo 2.0, we create a replacement (meta-file) image for
each OLE-object (esp. chart) to speed up loading and scrolling. In this document
the replacement file is different from the chart itself. You can verify this by
activating the chart (double-click).

->Timi: So, the question is: how did this inconsistency occur? You said it was
an Excel import. Maybe it would help, if you attached the Excel document to try
to reproduce a similar inconsistent file.
Comment 7 bjoern.milcke 2006-01-13 15:38:18 UTC
set myself on CC.
Comment 8 timi_openoffice 2006-01-13 20:27:53 UTC
I'll attach the original .xls file. I've reciebed it from somebody for using it
in a book, so I don't know with which version of Exel it was produced. At least
it is sure that originally the diagram was from up to down clear gray to dark
gray (following the attached prints, and I could also verify this with Excel
2000 on Win 2000, there working correctly.

However in OpenOffice this changes of the diagram color happens also when
working directly with the .xls-file, at least an OOo 2.0.1 / Windows 2000 and on OOo
1.9.125.1.2 (SuSE build coming with SuSE 10.0).
Comment 9 timi_openoffice 2006-01-13 20:31:56 UTC
Created attachment 33195 [details]
disired source document
Comment 10 kla 2006-02-14 10:11:51 UTC
Hi Bjoern,
the requested .xls file are attached. The behaviour is the same as described.
Pls have a look.
Comment 11 bjoern.milcke 2006-05-15 13:28:50 UTC
When opening the xls-Document I can reproduce the problem. Then, the gradient
properties (the black to white you get is the default) are indeed lost. The good
new is: this does not happen with the new chart. So, this is fixed for whenever
the new chart will be integrated into the product.

->DR: Do you know what the problem is here? Will it be easy to fix for the old
chart?
Comment 12 bjoern.milcke 2006-05-17 15:37:51 UTC
->dr: As discussed, this might be the problem with setting gradients (and other
stuff) via API with the object-properties rather tahn the named-properties.
Maybe changing the xls-import to named properties fixes this.
To reproduce: Load the xls-file, copy the visible chart to the clipboard and
paste -> the gradient is lost.
Comment 13 daniel.rentz 2006-05-17 15:56:53 UTC
started
Comment 14 daniel.rentz 2006-05-18 14:02:37 UTC
fixed in SRC680/dr48 (OOo 2.0.4)
Comment 15 niklas.nebel 2006-06-06 10:48:21 UTC
back to QA for verification

re-open issue and reassign to kla@openoffice.org
Comment 16 niklas.nebel 2006-06-06 10:48:25 UTC
reassign to kla@openoffice.org
Comment 17 niklas.nebel 2006-06-06 10:48:29 UTC
reset resolution to FIXED
Comment 18 kla 2006-06-12 10:27:19 UTC
*** Issue 66246 has been marked as a duplicate of this issue. ***
Comment 19 frank 2006-06-12 10:40:44 UTC
found fixed on cws dr48
Comment 20 kla 2006-07-07 14:46:38 UTC
*** Issue 66246 has been marked as a duplicate of this issue. ***
Comment 21 kla 2006-07-14 14:15:41 UTC
seen ok into the master -> closed
Comment 22 kla 2006-07-17 08:40:46 UTC
closed