Issue 60326 - Landscape pages (in subdoc) become portrait in MasterDocument
Summary: Landscape pages (in subdoc) become portrait in MasterDocument
Status: CLOSED DUPLICATE of issue 32141
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-01-10 19:34 UTC by lml
Modified: 2009-02-14 13:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A test case with a MasterDoc and two subdoc (16.10 KB, application/x-compressed)
2006-01-12 12:02 UTC, lml
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lml 2006-01-10 19:34:16 UTC
Maybe this issue is connected with (or the same as?) 34475 and 14253.
Problem description:
When you create a document using mostly portrait pages and some landscape pages
in it (so there should be a landscape page sytle in subdoc) and you add this
subdocument to a Master Document, the landscape pages became portrait.
I've tried to add the landscape page style to the master document
(File|Template|Organise) but the MD doesn't recognise the page style of the
subdoc, even it is (already) exist in the master document.

To create a test case:
Create a document with 3 pages: the 1. and 3. pages are portrait, the second is
landscape.
Add this doc to a master document.
The landscape page is no longer landscape (seeing from master).
Comment 1 michael.ruess 2006-01-11 07:09:04 UTC
Reassigned to ES.
Comment 2 eric.savary 2006-01-11 11:39:06 UTC
Please attach a sample document.
Comment 3 lml 2006-01-12 12:02:30 UTC
Created attachment 33141 [details]
A test case with a MasterDoc and two subdoc
Comment 4 lml 2006-01-12 12:22:05 UTC
The maindoc contains two subdoc. Test1 has 3 pages:
a portrait, a landscape, and a portrait (again).
Test1 uses the Default and "Landscape" page style.
The masterdoc has the same styles.

In Test2 the all document is landscape using with a Default style.
I think it is no problem, if Test2 doesn't landscape, because
the MD's Default style is portrait.
But style called "Landscape" should be landscape, because it is
landscape in the MD and in the SD. (It is copied with the
form\Templates\Organise from SD.)
Comment 5 lml 2006-01-12 12:24:47 UTC
The maindoc contains two subdoc. Test1 has 3 pages:
a portrait, a landscape, and a portrait (again).
Test1 uses the Default and "Landscape" page style.
The masterdoc has the same styles.

In Test2 the all document is landscape using with a Default style.
I think it is no problem, if Test2 doesn't landscape, because
the MD's Default style is portrait.
But style called "Landscape" should be landscape, because it is
landscape in the MD and in the SD. (It is copied with the
form\Templates\Organise from SD.)
Comment 6 eric.savary 2006-08-29 12:59:19 UTC
To use a change to landscape (or any other page attribute) in the middle of a
master document:
- after doc1 (portrait) inset a simple Text area (use the MD Navigator)
- In this text area, Insert - Page break - With style: Landscape

This is an FAQ. Please ask the user list for further information.
Comment 7 eric.savary 2006-08-29 13:00:13 UTC
closed
Comment 8 lml 2006-08-30 10:02:45 UTC
Ok, but my problem is not about changing the page layout of the whole subdoc (it
can be done setting on the Master Document, as you have written).
The problem is if a subdoc contains mixed page style (test1 is a subdoc with
portrait _and_ ladscape pages).
If the subdoc is seen from the MD, it can't use different page styles: all pages
of the subdoc are formatted  with the current pages style of the master doc.
(Even if it has two page-style change in it.)

To split the test1 subdoc to 3 document (a portrait, a landscape, and a
portrait) and insert them into the master document is not a perfect solution.
Imagine if a larger subdoc has more page-style change, and whe have more subdoc...

I think, when the subdoc is rendered into the MD, and it is contains a
page-break-with-style and the MD contains a page style with that name, then the
page style has to be changed and the following text of the subdoc should
formatted with the new page-style. 
(And the end of the subdoc, the page-style has to be changed back to the
original MD page style.)
Comment 9 lohmaier 2006-08-31 22:05:01 UTC
duplicate

*** This issue has been marked as a duplicate of 32141 ***
Comment 10 lohmaier 2006-08-31 22:05:40 UTC
closing duplicate.