Issue 60481 - Paletted pngs (1bpp) not displayed with correct color
Summary: Paletted pngs (1bpp) not displayed with correct color
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.1
Hardware: PC All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 3.3
Assignee: h.ilter
QA Contact: issues@gsl
URL:
Keywords: oooqa
: 93408 93410 104502 106628 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-01-13 11:42 UTC by ace_dent
Modified: 2017-05-20 10:23 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test image for paletted two-tone (1bpp) png (142 bytes, image/png)
2006-01-13 11:43 UTC, ace_dent
no flags Details
Screenshot of display problem (2.53 KB, image/png)
2006-01-13 11:44 UTC, ace_dent
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ace_dent 2006-01-13 11:42:12 UTC
Paletted pngs can have a range of bit depths as specified: for colour type 3,
valid bpp are 1,2,4,8...
http://www.libpng.org/pub/png/spec/1.2/PNG-Chunks.html#C.IHDR

This is often useful for web and icon style graphics. A two-tone image (1bpp)
with palette information was created, with blue text on a red background (see
attached Test image). 
- Import into Draw (although affects whole suite).
- View at 100%.
- Image appears as black and white: colour is lost! (see attached screenshot).
- However, when the image is scaled up or down (including page overview) the
true colours are shown correctly...

It seems other bit depths are unaffected.

Regards,
Andrew
Comment 1 ace_dent 2006-01-13 11:43:27 UTC
Created attachment 33177 [details]
Test image for paletted two-tone (1bpp) png
Comment 2 ace_dent 2006-01-13 11:44:34 UTC
Created attachment 33178 [details]
Screenshot of display problem
Comment 3 philipp.lohmann 2006-01-13 11:52:33 UTC
pl->hdu: another png issue
Comment 4 Rainer Bielefeld 2006-01-13 12:20:55 UTC
I checked with "2.0.1 RC5 German version WIN XP: [680m1(Build8990)]" and can
confirm the problem.

If I insert the image on 100% using page zoom, it will look "black and white".
Funny thing, if I resize image to double size (exactly both dimensions manually
adjusted to double size), the view becomes "blue text on red ground" (as
expected), but if I change page zoom to 50%, I have it "black and white" again.

@ace_dent:
please specify your OS and Platform!
Comment 5 Rainer Bielefeld 2006-01-13 12:40:15 UTC
I did some further tests:
Print with officejet  6110: always blue text on red ground
PDF-export: always "black & white"
Comment 6 ace_dent 2006-01-13 14:10:53 UTC
Hi, 
sorry didn't think that this might be OS specific.

OS: Win XP SP2 (PC!)
OOo: 680m146 b8991

Cheers.
Comment 7 hdu@apache.org 2006-02-09 11:40:45 UTC
.
Comment 8 ace_dent 2006-07-04 21:31:57 UTC
This problem has stumped me a couple of times now. Any chance of setting the target?
Comment 9 hdu@apache.org 2006-07-13 09:28:57 UTC
Retargeted after CWS pngperf.
Comment 10 Martin Hollmichel 2008-01-28 02:31:41 UTC
set target 3.x
Comment 11 michael.ruess 2009-08-26 07:01:47 UTC
*** Issue 104502 has been marked as a duplicate of this issue. ***
Comment 12 ace_dent 2009-10-06 14:41:20 UTC
*** Issue 93410 has been marked as a duplicate of this issue. ***
Comment 13 ace_dent 2009-11-05 21:14:27 UTC
*** Issue 106628 has been marked as a duplicate of this issue. ***
Comment 14 kpalagin 2009-11-06 09:44:13 UTC
Herbert,
please copnsider this issue for 3.3 as you say there is some cws pending.
Thanks&regards.
Comment 15 hdu@apache.org 2009-11-10 15:49:45 UTC
The generic PNG problem seems to be fixed but the PDF-export loses the color.
Reassigning, feel free to use this issue for the remaining PDF-problem or reopen one of the duplicates 
which is more PDF-specific.
Comment 16 philipp.lohmann 2010-03-23 18:55:39 UTC
fixed the PDF problem in CWS vcl110
Comment 17 philipp.lohmann 2010-03-26 15:29:37 UTC
please verify in CWS vcl110
Comment 18 h.ilter 2010-04-07 20:24:38 UTC
Verified with cws vcl110 = ok 
Comment 19 philipp.lohmann 2010-04-30 14:39:53 UTC
*** Issue 93408 has been marked as a duplicate of this issue. ***