Issue 60586 - implement filters for Office Open XML (aka OOXML, aka MS Office 2007)
Summary: implement filters for Office Open XML (aka OOXML, aka MS Office 2007)
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.1
Hardware: All All
: P3 Trivial with 23 votes (vote)
Target Milestone: OOo 3.0
Assignee: michael.ruess
QA Contact: issues@framework
URL: http://openxmldeveloper.org/
Keywords: oooqa
: 75330 83001 85863 90231 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-01-15 16:26 UTC by computerhotline
Modified: 2010-11-11 03:00 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Here, there is an Word file format in Office Open XML Format (11.13 KB, application/msword)
2006-01-17 15:43 UTC, computerhotline
no flags Details
A Excel 12 file (8.55 KB, application/vnd.ms-powerpoint)
2006-02-12 10:48 UTC, computerhotline
no flags Details
A PowerPoint 12 file (29.46 KB, application/vnd.ms-powerpoint)
2006-02-12 10:49 UTC, computerhotline
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Comment 1 lars 2006-01-15 19:06:29 UTC
so that these issues are not unconfirmed (and perhaps unnoticed): confirmed
Comment 2 computerhotline 2006-01-16 13:52:37 UTC
OOo could integrate these file format
Comment 3 computerhotline 2006-01-17 15:43:42 UTC
Created attachment 33304 [details]
Here, there is an Word file format in Office Open XML Format
Comment 4 thorsten.martens 2006-01-30 13:37:29 UTC
TM->requirements: Please have a look, thanks !
Comment 5 computerhotline 2006-02-12 10:48:19 UTC
Created attachment 34082 [details]
A Excel 12 file
Comment 6 computerhotline 2006-02-12 10:49:07 UTC
Created attachment 34083 [details]
A PowerPoint 12 file
Comment 7 computerhotline 2006-04-09 09:40:55 UTC
Here, the is a web site about OpenXML :
http://openxmldeveloper.org/
Comment 8 computerhotline 2006-06-16 17:16:24 UTC
Here, there is another "OpenXML" file :
http://www.almateam.com/CdM%20XaMaLa/CdM%202006%20XaMaLa%20v3.4.xlsx
Comment 9 computerhotline 2006-07-20 18:21:43 UTC
The XML Schema Reference (bêta 2) are available here :
http://www.microsoft.com/downloads/details.aspx?FamilyId=15805380-F2C0-4B80-9AD1-2CB0C300AEF9&displaylang=en
Comment 10 andreschnabel 2006-07-20 18:30:33 UTC
changed summare to have a better idea, what this issue is about
Comment 11 computerhotline 2006-11-10 19:44:39 UTC
Ecma Office Open XML File Formats Standard - Final draft - 9th of October 2006 :
http://www.ecma-international.org/news/TC45_current_work/TC45-2006-50_final_draft.htm

OpenXML Developper :
http://openxmldeveloper.org/
----
To interate in OOo
Comment 12 andreschnabel 2006-11-10 19:56:02 UTC
as novell has announced to implement the OOXML support in OOo, maybe mmeeks
could assign to correct person and take care about the issue
Comment 13 mmeeks 2006-11-13 12:54:28 UTC
this is a big 'ole feature across several components, with many possible
implementation choices, sadly it's not just as easy as assigning a bug to
someone :-) however, thanks for the CC on this.
Comment 14 ace_dent 2007-03-12 21:25:24 UTC
*** Issue 75330 has been marked as a duplicate of this issue. ***
Comment 15 gtimur 2007-04-10 13:58:05 UTC
Novell's plugin is not a solution:
http://www.linux.com/article.pl?sid=07/03/12/1654255
Comment 16 aziem 2007-10-27 16:37:56 UTC
*** Issue 83001 has been marked as a duplicate of this issue. ***
Comment 17 gtimur 2007-10-31 18:32:51 UTC
I understand that OO team is overwhelmed with different requests. 
Still, I have a question: is this filter for Office Open XML much easier to make
than that for Office 97-2003, because Open XML has an open specification, and
for Office 97-2003 filter you had to use reverse engineering?
Comment 18 kpalagin 2008-02-06 19:16:17 UTC
*** Issue 85863 has been marked as a duplicate of this issue. ***
Comment 19 michael.ruess 2008-02-29 08:14:23 UTC
This will be implemented for OO 3.0. See also issue 75573; the CWS name is
"xmlfilter03". Will be available in one of the first DEV300 builds following the
OO 2.4 builds.
Comment 20 michael.ruess 2008-02-29 08:16:08 UTC
Setting to "fixed". The CWS will be integrated into DEV300 codeline soon.
Comment 21 michael.ruess 2008-02-29 08:24:07 UTC
setting to "verified", means that the code will be integrated soon.
Comment 22 michael.ruess 2008-04-01 08:53:00 UTC
A kind of pre-alpha of the filter(s) is now available in DEV300 builds. Please
do not submit any issue related to the quality of these as soon as it has not
reached beta state.
Comment 23 aziem 2008-06-02 04:58:21 UTC
*** Issue 90231 has been marked as a duplicate of this issue. ***
Comment 24 jr 2008-07-15 11:46:52 UTC
*** Issue 85863 has been marked as a duplicate of this issue. ***
Comment 25 writedinlo 2010-11-11 03:00:12 UTC
Created attachment 74090