Issue 60787 - Icon Switching: "New File" images not updated correctly
Summary: Icon Switching: "New File" images not updated correctly
Status: CLOSED DUPLICATE of issue 86924
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: 680m150
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: kendy
QA Contact: issues@ui
URL:
Keywords:
: 62659 62792 62793 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-01-18 23:12 UTC by ace_dent
Modified: 2008-03-12 11:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
<1> First run with Default theme (9.79 KB, image/png)
2006-01-18 23:13 UTC, ace_dent
no flags Details
<2> Switching to HC theme. File type icons not updated. (9.41 KB, image/png)
2006-01-18 23:14 UTC, ace_dent
no flags Details
<3> New document in HC theme, still with wrong icons. (9.56 KB, image/png)
2006-01-18 23:15 UTC, ace_dent
no flags Details
<4> Quickstarter in HC theme, with wrong file icons (12.34 KB, image/png)
2006-01-18 23:16 UTC, ace_dent
no flags Details
<5> After relaunching Writer, file icons are in HC theme. (5.20 KB, image/png)
2006-01-18 23:17 UTC, ace_dent
no flags Details
<6> Switching back to Default theme, still shows HC icons (5.45 KB, image/png)
2006-01-18 23:18 UTC, ace_dent
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ace_dent 2006-01-18 23:12:32 UTC
This relates to Issue 36518 (Icon Switching).
The following steps correspond to the attached screenshots (SS). The main
problem described is that file type icons are not updated when switching themes.

<1>
Writer loaded with Default theme. New file drop down shows correct icons (SS1).
<2>
Icons switched to High Contrast (HC). (Ref: SS2)
Error1: Toolbar icon for 'New' file, now corresponds to icon used for
'File'>'New', rather than the default new file icon of Writer file. (Compare to
SS5).
Error2: File type icons are still using previous theme.
<3>
Still in HC theme. Launch a new Writer document (SS3). Now has correct Writer
'New' file icon, but still all in Default theme and not HC.
<4>
Also (still in HC), the file types listed by the Quickstarter 'Templates and
Documents' are not in HC as required (SS4).
<5>
Still in HC theme, exit OOo and close down Quickstarter. On restarting Writer,
the HC theme is now fully implemented for file type icons (SS5).
<6>
For completeness: Switching back to Default theme, yields similar results to
<2>. Note that the Toolbar 'New' file icon is wrong (should be Writer not
blank), and HC icons for file types instead of Default as expected.

Regards,
Andrew
Comment 1 ace_dent 2006-01-18 23:13:30 UTC
Created attachment 33354 [details]
<1> First run with Default theme
Comment 2 ace_dent 2006-01-18 23:14:22 UTC
Created attachment 33355 [details]
<2> Switching to HC theme. File type icons not updated.
Comment 3 ace_dent 2006-01-18 23:15:36 UTC
Created attachment 33356 [details]
<3> New document in HC theme, still with wrong icons.
Comment 4 ace_dent 2006-01-18 23:16:24 UTC
Created attachment 33357 [details]
<4> Quickstarter in HC theme, with wrong file icons
Comment 5 ace_dent 2006-01-18 23:17:34 UTC
Created attachment 33358 [details]
<5> After relaunching Writer, file icons are in HC theme.
Comment 6 ace_dent 2006-01-18 23:18:54 UTC
Created attachment 33359 [details]
<6> Switching back to Default theme, still shows HC icons
Comment 7 ace_dent 2006-01-18 23:42:02 UTC
.
Comment 8 ace_dent 2006-03-05 14:55:46 UTC
*** Issue 62793 has been marked as a duplicate of this issue. ***
Comment 9 ace_dent 2006-03-05 20:14:23 UTC
*** Issue 62792 has been marked as a duplicate of this issue. ***
Comment 10 ace_dent 2006-03-05 20:14:47 UTC
*** Issue 62792 has been marked as a duplicate of this issue. ***
Comment 11 kendy 2006-07-18 17:02:50 UTC
*** Issue 62659 has been marked as a duplicate of this issue. ***
Comment 12 Mathias_Bauer 2008-03-12 11:13:15 UTC
this issue is fixed by a patch provided by cmc

*** This issue has been marked as a duplicate of 86924 ***
Comment 13 Mathias_Bauer 2008-03-12 11:15:50 UTC
closing duplicate