Issue 60938 - postgresql-sdbc: import from calc spreadsheet produces wrong schema name
Summary: postgresql-sdbc: import from calc spreadsheet produces wrong schema name
Status: CONFIRMED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-21 13:21 UTC by umehlig
Modified: 2013-08-07 15:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description umehlig 2006-01-21 13:21:30 UTC
I tried to import a table from a calc spreadsheet to a postgresql database
accessed via the sdbc postgresql driver 0.6.2. 

I did this by copying a data range from the spreadsheet to the clipboard and
pasting it to the "Tables" area of the OOBase window for the PostgreSQL
datasource. The Import wizard appears but when trying to save the new table to
the database, PostgreSQL complains about a wrong schema name (should be
"public", not "xxx").

The database name is "xxx", the user name also "xxx" (true names of database,
user and columns substituted by placeholders here and in the error message below).

Hope this helps to fix it ...
Regards, Ulf

PostgreSQL 8.1.2, Linux 2.6.15/i386, OpenOffice 2.0.0-1bpo3 from
www.backports.org (for Debian sarge), sdbc postgresql driver 0.6.2

Error code: 1

pq_driver: [PGRES_FATAL_ERROR]ERROR:  schema "xxx" does not exist
 (caused by statement 'CREATE TABLE "xxx"."test" ( "aaaaa" varchar(35),  "bbbbb"
varchar(35),  "ccccc" varchar(35),  "ddddd" varchar(10),  "eeeee" int2,  "fffff"
char(1),  "ggggg" float8,  "hhhhh" varchar(35)) ')
Comment 1 umehlig 2006-01-27 07:10:00 UTC
I just tested the same connection after deinstallation of the old and
installation of the new (v. 0.7.0) driver. OObase does not crash any more, but
when the SQL button is toggled, the query result is empty ("select * from
aaaa"), while without toggling the SQL button, the table contents is listed as
expected.

Regards, Ulf 
Comment 2 umehlig 2006-01-27 07:24:14 UTC
Please disregard the previous comment, it was meant for a different issue I was
preparing ... typing in the wrong window :-(

However, the problem described in this issue persists with the new driver 0.7.0.

Ulf
Comment 3 christoph.lukasiak 2006-02-07 15:43:04 UTC
i can repro that - looks like we could not handle the shema

clu->oj: msc tried the same with mysql on linux and schema and there came no
error messages, but the table disappeared - maybe, you should have a look on
this in general
Comment 4 canita 2006-07-06 14:22:51 UTC
I have the same problem with OOo 2.0.2 FSF.hu build 4 Premium, postgreSQL-8.0
(8.0.7-2build1), SDBC 0.7.2, Ubuntu Dapper. 
Comment 5 Mechtilde 2008-05-05 11:30:27 UTC
I set it to new because clu can reproduce it.