Issue 60945 - different line heights for Windows<->Unix caused by "external leading" font metric
Summary: different line heights for Windows<->Unix caused by "external leading" font m...
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.1
Hardware: All Unix, all
: P3 Trivial (vote)
Target Milestone: OOo 2.2
Assignee: eric.savary
QA Contact: issues@gsl
URL:
Keywords: needmoreinfo, oooqa
: 61364 65245 73811 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-01-21 16:55 UTC by kboo
Modified: 2010-09-18 18:05 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample doc with line metric compatibility to OOo20 (7.48 KB, application/vnd.oasis.opendocument.text)
2006-10-10 14:40 UTC, hdu@apache.org
no flags Details
Sample doc with better line metric compatibility to WIN (7.42 KB, application/vnd.oasis.opendocument.text)
2006-10-10 14:40 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kboo 2006-01-21 16:55:20 UTC
when I save a file in odt on the Linux version of Ooo ( a CV ) where I changed
the suze of the text on the paper when I go on Windows with exactl the same
version the text is too long. I use A4 format, ae_Metal police, so this problem
make the odt format looks like ununiversal, it makes the credibility of open
format in a  very bad position I think compre to the doc format on MS-Word. I
hope something will be done quick for the credibility of the Openoffice project.
Comment 1 askoorb 2006-01-22 17:23:10 UTC
kboo, please attach to this issue an example screenshot from both linux AND
windows so we know exactly what's going on.  The document in question that isn't
working would also help.

I cannot confirm without this as I don't have access at the moment to a linux box.

Oh, and a P1 issue is:

P1 marks extremely severe problems.
Issues with this priority must be fixed immediately, and the fix must be
included in the next available build of the application.
Not fixing those issues is simply impossible.
There's rarely anything which really qualifies as P1 issue!

Please see http://www.openoffice.org/scdocs/ddIssues_EnterModify.html#priority
before filing any more issues.

I think this would classify as "Functionality violates its specification"  so I
am dropping to a P3.
Comment 2 stephan_schaefer 2006-01-24 17:38:51 UTC
reassign
Comment 3 hdu@apache.org 2006-02-13 17:21:37 UTC
The reason is most probably that the available fonts on Windows<->Linux are not
identical. If the font selected for text is not available on both platforms the
formatting will be different.
Comment 4 hdu@apache.org 2006-03-14 12:00:32 UTC
accepted
Comment 5 hdu@apache.org 2006-06-27 11:54:22 UTC
Am still looking for a way to fix this with minimal impact on existing layouts...
Comment 6 hdu@apache.org 2006-09-29 14:16:02 UTC
Will be fixed in CWS extleadfix by using a compatibility flag for older documents.
Comment 7 hdu@apache.org 2006-09-29 15:08:27 UTC
@fme: when creating the reference device please provide a
REFDEV_FORCE_ZERO_EXTLEAD flag if needed for keeping the layout of documents
that were formatted before the fix.
Comment 8 frank.meies 2006-10-09 14:33:35 UTC
FME->HDU: Done. Back to you.
Comment 9 hdu@apache.org 2006-10-10 14:40:20 UTC
Created attachment 39666 [details]
Sample doc with line metric compatibility to OOo20
Comment 10 hdu@apache.org 2006-10-10 14:40:55 UTC
Created attachment 39667 [details]
Sample doc with better line metric compatibility to WIN
Comment 11 hdu@apache.org 2006-10-10 14:52:30 UTC
Reassigning for verification
Comment 12 hdu@apache.org 2006-10-10 14:59:19 UTC
Fixed in CWS extleadfix.

@ES: Please verify.
Testing hints:
There are two different test aspects: Better Win<->Unx compatibility and
Unx<->Unx backward compatibility for older documents:

  WIN<->UNX compatibility:
  - compare the attached i60945_mini_oo21.odt file on UNX and WIN
  - try with different fonts
  - try with different sample documents, e.g. *.doc files

  UNX<->UNXcompatibility:
  - compare the attached i60945_mini_oo21.odt file on UNX with older OOo versions
  - try with different fonts
Comment 13 eric.savary 2006-10-20 14:46:27 UTC
Verified
Comment 14 Martin Hollmichel 2006-10-27 08:53:01 UTC
adjust target
Comment 15 hdu@apache.org 2006-10-27 14:30:27 UTC
Adjusting issue summary to root cause.
Comment 16 hdu@apache.org 2006-10-30 10:38:11 UTC
*** Issue 65245 has been marked as a duplicate of this issue. ***
Comment 17 hdu@apache.org 2006-10-31 08:49:36 UTC
*** Issue 61364 has been marked as a duplicate of this issue. ***
Comment 18 eric.savary 2007-01-18 12:28:53 UTC
closed
Comment 19 hdu@apache.org 2007-01-24 07:50:05 UTC
*** Issue 73811 has been marked as a duplicate of this issue. ***
Comment 20 michael.ruess 2007-03-15 09:10:20 UTC
*** Issue 75405 has been marked as a duplicate of this issue. ***
Comment 21 rpolach 2007-04-25 10:08:52 UTC
Is this bug really fixed?
I still see this problem in 2.2

(Ubuntu Feisty, OOo version 2.2.0-1ubuntu3)
Comment 22 eric.savary 2007-04-25 10:46:24 UTC
Please use the build from the OOo Site.
Comment 23 rpolach 2007-10-20 13:07:03 UTC
I still see this problem in 2.3.0 (Ubuntu Gutsy Final). Reopen please?

http://www.openoffice.org/nonav/issues/showattachment.cgi/43709/test_arial.odt
( from dupe http://www.openoffice.org/issues/show_bug.cgi?id=75405 )
still shows page break between 54. and 55. line instead of between 52. and 53. line.
Comment 24 rpolach 2007-11-05 15:35:50 UTC
does anybody experience this problem fixed?
Comment 25 hdu@apache.org 2007-11-06 08:04:36 UTC
Adjusting the summary line to the root cause of this issue.