Issue 61075 - Fields from Endnote skipped during Word import in OOo 2
Summary: Fields from Endnote skipped during Word import in OOo 2
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.1
Hardware: All All
: P3 Trivial with 21 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
Keywords: regression
: 61437 83574 85902 (view as issue list)
Depends on:
Blocks: 89667
  Show dependency tree
Reported: 2006-01-24 02:37 UTC by sajer
Modified: 2013-08-07 14:42 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Original Word XP document (24.50 KB, application/msword)
2006-01-24 02:38 UTC, sajer
no flags Details
Imported into Writer 1.1.5 (It works) (7.26 KB, application/vnd.sun.xml.writer)
2006-01-24 02:40 UTC, sajer
no flags Details
Imported into Writer 2.0.1 (Doesnt work) (11.88 KB, application/vnd.sun.xml.writer)
2006-01-24 02:41 UTC, sajer
no flags Details
PNG image showing file imported in Writer 1.1.5 (9.83 KB, image/png)
2006-01-24 02:42 UTC, sajer
no flags Details
PNG image showing file imported in Writer 2.0.1 (1.46 KB, image/png)
2006-01-24 02:43 UTC, sajer
no flags Details
Contains field whose field code contains a "/" (21.50 KB, application/msword)
2007-12-12 14:02 UTC, openoffice
no flags Details
word 2000 document with field inserted by bibus, which disappear during import in OO 2.4 (30.00 KB, application/msword)
2008-03-28 09:46 UTC, brendel
no flags Details
.doc file with fields created by Bibus in Word2003 that disappear when opened with OO2,.4 (27.00 KB, application/msword)
2008-05-19 16:06 UTC, brendel
no flags Details
Sample endNote document with missing field (40.50 KB, application/msword)
2009-08-14 12:39 UTC,
no flags Details
Patch fixing the issue properly (957 bytes, patch)
2009-08-14 12:41 UTC,
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description sajer 2006-01-24 02:37:38 UTC
Look at the attached files. In the MS Word document (from Word XP, Danish
edition) I added a few references in the footnotes using EndNotes insert
reference feature.

This adds fields to the footnote. After the reference I add ", page 2" etc.

This fields were imported by Writer 1.1.x as pure text (better than nothing),
but in Writer 2.0.x the fields are just skipped, leaving my ", page 2" alone in
the note.

I have attached some evidence :)
Comment 1 sajer 2006-01-24 02:38:23 UTC
Created attachment 33504 [details]
Original Word XP document
Comment 2 sajer 2006-01-24 02:40:08 UTC
Created attachment 33505 [details]
Imported into Writer 1.1.5 (It works)
Comment 3 sajer 2006-01-24 02:41:14 UTC
Created attachment 33506 [details]
Imported into Writer 2.0.1 (Doesnt work)
Comment 4 sajer 2006-01-24 02:42:41 UTC
Created attachment 33507 [details]
PNG image showing file imported in Writer 1.1.5
Comment 5 sajer 2006-01-24 02:43:06 UTC
Created attachment 33508 [details]
PNG image showing file imported in Writer 2.0.1
Comment 6 michael.ruess 2006-01-24 09:01:37 UTC
It is a kind of User-defined field. This cannot be imported as is, but we can
import it as user field with correct content and name.
Comment 7 michael.ruess 2006-01-31 18:33:03 UTC
*** Issue 61437 has been marked as a duplicate of this issue. ***
Comment 8 hvbakel 2006-08-16 11:12:18 UTC
Just to add my support for this bug, it would be great if OO could just
import/save these fields as they are, so that it is possible to collaborate on
manuscripts that use Endnote through OO writer.
Comment 9 Mathias_Bauer 2006-08-30 15:29:13 UTC
assigning to hbrinkm
Comment 10 brendel 2006-09-13 09:01:12 UTC
I have encountered the same problem and this is really awkward as many
scientists use EndNote to manage their references and include them in their
manuscripts. As long as I cannot see these fields I cannot use OO to work on
these documents. I have used OO for quite a while now but this problem forces me
to go 100% back to Word. I would appreciate very much if anything could be done
about this problem.
Thanks a lot in advance
PS If needed I have example files. I won't attach them for now as there are
already files attached.
Comment 11 brendel 2006-09-13 09:11:31 UTC
By the way, I think this is a problem that must have been caused by changes in
one of the recent versions. I cannot check or prove this, but I have just
checked some older manuscripts from autumn 2005 and January/February 2006 and
these documents also contain EndNote fields and I have no recollection about
having had any problems with this. So either this is a problem in the newer OO
versions or EndNote has changed their field format and this caused the problem.
If somebody wants to check this, I could produce example files from these older

Comment 12 sajer 2006-10-06 01:42:50 UTC
It worked in OOo 1.1.5 so we are talking about a regression in 2.0.x
Comment 13 mcswell 2007-01-13 22:32:04 UTC
I'll just agree with some of the previous respondents.  OO _must_ not damage
EndNote fields (they don't necessarily have to be editable inside OO, but it
can't destroy them, as it does now).  I use MS Word and EndNote at work, and I
can't change that.  I was using OO to work on the same docs at home.  I don't
want to, but it looks like I'm going to have to buy Word to use at home when I
need to work on docs from here.
Comment 14 parrenin 2007-01-14 12:02:23 UTC
I am really surprised this old issue has not been fixed yet.
I think OOo is losing plenty of users in academia because of this.
As long as you cannot use it to open manuscripts sent by other collegues, OOo
seems useless (even just for printing such a document, all references are
Even if the fields are lost, an import of the text of the fields as was done in
version 1.1.5 of OOo would be more than appreciated.
Thanks in advance.
Comment 15 fenchurch 2007-02-05 13:56:32 UTC
It would be very nice if OOo could do this, for any kind of Word field.  Even if
it just ignored the code or represented it as the actual characters used, that
would be fine with me.
Comment 16 dfd 2007-02-15 00:44:05 UTC
This is an extremely important issue in the academic sphere.  It prevents most
acadenics and researchers from using OO and in turn from using open source systems
like Linux.
Comment 17 hvbakel 2007-03-31 00:52:43 UTC
Unfortunately this still isn't fixed in version 2.2
Comment 18 amternes 2007-10-05 12:46:46 UTC
I agree with "dfd", in a mixed academic environment, documents with EndNote
cannot be read by those team members using OpenOffice. Please implement this
feature, so that scientists can be convinced to convert to open-source software!
Comment 19 brendel 2007-10-10 08:35:59 UTC
I'm quite amazed that this bug, a regression as it worked in older versions, has
been known for one-and-a-half years and has not received any attention of the
programmers. I'm not complaining about it not being fixed, this is a problem of
priorities, but there also has not been any discussion on this being an issue to
repair (has worked before),  how to perhaps fix this, etc. 
and this is not only a problem with EndNote, also Bibus fields seem to disappear
(when created under OO, exported to Word, reimported). So I guess this might be
a problem with all Reference software using fields. 
Thus this is not only concerning a few EndNote users, but anybody who wants to
write a text that includes literature references.
Comment 20 brendel 2007-10-25 08:26:42 UTC
I would like to add that this bug also affects BIBUS, one of the very few
bibliographic programmes that work properly with OpenOffice. The programmer has
made a big effort so that his program will work with both , Word and OpenOffice.
And now the use of this very usefull and free program is severely handicapped by
this bug in OpenOffice. I have a number of students using Bibus for their
bibliographies, and using Word (on institute computers) and OpenOfice (on
personal computers) and basically related to this bug, they cannot import the
word files with bibliographic fields into OO. I'm trying to use mainly
OpenOffice and promote it within the scientific community, but not being able to
see neither EndNote nor Bibus field is a severe handicap. Even I, a longterm
user and defender of OpenOffice in a still rather MSWord.using environment will
have to switch back to Word now. There is nothing I can do, I'll have to abandon
OpenOffice because I cannot see the bibliographic fields. 
What bothers me especially with this bug is that a programmer of a very usefull
 free programm, hasmade the effort to make it work with OpenOffice, and
OpenOffice leaves a bug, that is a regression (as this has worked before)
seemingly without comment and concern. When programmers of free programmes do
not stick together, where do we go ?

Comment 21 jayze 2007-10-25 10:39:19 UTC
I would like to add my support for this bug/issue to be resolved. Our research 
programme is now busy compiling a database of relevant articles and research 
in EndNote. No doubt once the Bibliographic Manager is integrated into OOo, a 
few of us will probably want to import our records into OOo. I cannot 
understand why such a critical issue has not been resolved, given the amount 
of people (including potential users of OOo) it affects, and the time it has 
been on the system, as well as the number of votes it has. An appeal to the 
developers: please make this a priority and get it sorted out. Otherwise we 
might as well go back to using OOo 1.1.5.
Thank you
Comment 22 sajer 2007-10-27 01:48:56 UTC
I reported this bug in 2006 and I say: Don't bother waiting. My experience tells
me that OOo will initially save you some money, and then waste your time for
years. You will loose hours on trying to get it working, loose years waiting for
bugfixes or new features we had in Word since 1995.

I gave up. I am now happily working with MS Word and Endnote. WORKING!

If time is money (and/or knowledge), OpenOffice is not free. Save yourself.
Comment 23 mcswell 2007-10-27 02:23:47 UTC
I concur with  sajer: I went out and bought a copy of Microsoft Word
specifically because of this bug.  I *have* to have bibliographic fields in my
documents, and since at work I use Word + EndNote, I have to preserve those
fields when I work at home.  (And since Writer destroys those fields, I have no
confidence that it doesn't destroy other fields as well.)
Comment 24 fenchurch 2007-10-29 13:57:40 UTC
I just wanted to add that I am very disappointed that this has not been touched.
 If I can find it, I am going to revert to 1.5.  One of the major reasons for
using OOo is the ability to switch between Word and OOo, but this field problem
makes it fairly unusable.  It is extremely annoying to either lose the
functionality of fields by saving them as plain text or lose the field
information completely if you forget to do this.  Making these changes manually
in a 100,000 word document is not really a very pleasant prospect.
Comment 25 michael.ruess 2007-11-13 07:39:21 UTC
*** Issue 83574 has been marked as a duplicate of this issue. ***
Comment 26 ramc18 2007-11-19 13:55:59 UTC
We are very interesed in this issues because we have a Real Estate application
that uses Word documents with fields that are filled with database data in order
to print some documents as invocies, forms, etc.

The main problem that we have to support is that the fields are
not imported in Writer from Word. This means that any change to the Word
documents implies that manually we must recreate all the fields.

We don't understand why the Word fields are not imported in Writer. Write is a grest application but this kind of support to Office
integration applications will accelerate the spread of use.
Comment 27 Mathias_Bauer 2007-11-19 14:43:00 UTC
This issue is one of numerous examples how MS interop thrashes our development
resources. The necessity to implement a new import filter for the OOXML formats
nearly binds all resources in that area and burns several person years
development time that now is missing to fix remaining bugs in the old filter.

So we have to select issues in the "old" filter very carefully and we can fix
only the most important ones, otherwise we won't be able to finish the OOXML
import in time for OOo3.0 Beta. Of course it is always possible to have
different assessments for the importance of particular issues - so bear with us
if sometimes we have others than you. The pure fact that an issues is one, two,
three or more years old does not tell us anything about its importance.

This particular issue is unfortunate because it is a regression and so I
immediately raised its priority when I became aware of that. That means we try
to fix that in the next possible version.
Comment 28 fenchurch 2007-11-19 15:29:00 UTC
Thank you for elevating the priority of this problem.  
Comment 29 openoffice 2007-12-12 13:56:54 UTC
Comment 30 openoffice 2007-12-12 14:00:20 UTC
reopen: need to add some QA information
Comment 31 openoffice 2007-12-12 14:02:16 UTC
Created attachment 50259 [details]
Contains field whose field code contains a "/"
Comment 32 openoffice 2007-12-12 14:04:14 UTC
attached document contains .doc with a field whose field code contains a "/".
When imported, there should be no text imported from this field.
Comment 33 openoffice 2008-01-07 13:47:41 UTC
ready for QA.
Comment 34 michael.ruess 2008-01-08 15:18:25 UTC
Verified fix in CWS sw8u10bf04.
Comment 35 michael.ruess 2008-02-08 15:08:46 UTC
*** Issue 85902 has been marked as a duplicate of this issue. ***
Comment 36 michael.ruess 2008-03-05 13:36:11 UTC
Checked fix in OOH680m8 (OOo 2.4) and SRC680m247 (OOo3 branch).
Comment 37 brendel 2008-03-28 09:37:22 UTC
The fix does not seem to work for Bibus fields : I just tried the new 2.4
release : I opened a test document created using WORD 2000 and Bibus. There were
two fields in the text from Bibus for citing a reference and then the field for
the Bibliography. Opening this file in OO writer 2.4 has the fields disappearing
(as in OO 2.3). I have atached the file

Comment 38 brendel 2008-03-28 09:46:27 UTC
Created attachment 52342 [details]
word 2000 document with field inserted by bibus, which disappear during import in OO 2.4
Comment 39 dwiniecki 2008-03-31 14:41:47 UTC
On my PC (WinXP sp2), if MS-Word is not installed, the fields are changed to
text in import to OOo 2.4 Writer.  If MS-Word is installed on the computer, the
fields are not imported.  

Regardless, importing only the text without the field codes is not ultimately
useful or acceptable for people collaborating on projects with those who use
Endnote.  I urge the OOo project to fully accommodate these fields.  The
sentiment expressed by others--that not doing so effectively makes OOo so
inconvenient that it is unusable by many.
Comment 40 Mathias_Bauer 2008-03-31 16:08:36 UTC
I don't remember if we mentioned that already in this issue, but we will indeed
improve the import later. This issue here was only meant as a request to restore
what OOo 1.x already was able to do (import the fields as text).
Comment 41 mcswell 2008-03-31 16:42:51 UTC
Apropos of the final couple comments (on importing as text), I think the key
issue is people who use MsWord at the office, and OO Writer at home.  The need
in that context is to be able to send documents back and forth in both
directions without losing information.  If every time you work on a document at
home using Writer, the EndNote (etc.) fields turn into plain text, then this
simply doesn't work: you don't want to have to go through some process to
convert them back into fields when you get back to the office.

At least if I'm understanding what is being said here, that process is a
show-stopper.  I should clarify that I long ago gave up on OO because of this
problem, and bought and installed MsOffice on my home computer.  But if you want
to avoid more losses to Microsoft Office, fixing this (assuming I understand
correctly) needs to be a high priority.

   Mike Maxwell
Comment 42 Mathias_Bauer 2008-04-01 07:03:40 UTC
Whatever the relevance of this issue is, there is a fundamental problem with
Writer's text fields that make fixing it very hard and so it is still not done.
But we will improve that in (not so far) future versions. Watch changes in
Writer concerning meta data and bibliographic support.
Comment 43 debyld 2008-05-07 07:57:54 UTC
How can this be marked as fixed when clearly it is not?

It appears that OOo isn't escaping xml in fields, instead it ignores the data,
is this the problem?

What issues have been logged that relate to this is? This is the only one I have
found which is clear about the problem.
Comment 44 Mathias_Bauer 2008-05-11 17:06:54 UTC
This issue is not about the missing support for "real" import, it is about the
regression that the fields are not imported at all (not even as text as in older
versions). *This* problem is fixed.

I don't know if there is another issue about the complete support. If not,
please feel free to add one.
Comment 45 brendel 2008-05-19 16:01:52 UTC
Sorry to tell you this, but the problem is not fixed : when I create a .doc
document and inserting fields, for example with the free bibliographic programm
"Bibus", then these fields are not imported when the file is opened in OO2.4,
also not as simple text. They simply disappear (each citation and the whole
bibliography). i have tried this with .doc documents created with Word2000 and
Word2003, same result. I don't know what the difference is between EndNote and
Bibus fields, but it is not working for Bibus. If the fields would shown at
least as text, I would consider this issue as closed.
I have attached a test file created using Word 2003 and Bibus 2.4


Comment 46 brendel 2008-05-19 16:06:12 UTC
Created attachment 53767 [details]
.doc file with fields created by Bibus in Word2003 that disappear when opened with OO2,.4
Comment 47 michael.ruess 2008-05-19 21:35:49 UTC
Olivier, could you please file a new issue for this problem? I assume, that it
is a diffrerent thing.
Comment 48 brendel 2008-05-20 07:36:01 UTC
OK, created a separate issue for Bibus fields : 89667
Comment 49 thb 2009-08-14 12:38:11 UTC
Still endnote fields are skipped/not imported correctly in 3.1.1
Comment 50 2009-08-14 12:39:38 UTC
Created attachment 64160 [details]
Sample endNote document with missing field
Comment 51 2009-08-14 12:41:02 UTC
Created attachment 64161 [details]
Patch fixing the issue properly
Comment 52 michael.ruess 2009-08-18 11:16:21 UTC
The original problem has been fixed here (and is still in OOo 3.x). The newly
attached document shows a special case of the Endnote field having additional
"Quote" keyword in its field syntax.
Please do not re-open already fixed issues (which are really fixed for the
attached testcases); issues will get extremely inconvenient to handle then.
Please file a new issue for this new testcase. Thanks for your patience.
Comment 53 michael.ruess 2009-08-18 11:17:26 UTC
Please file a new issue for the latest sample.
Comment 54 2009-09-01 13:25:12 UTC
mru: I reopened the issue for a simple reason: the previous fix only fixed some
particular fields... but there were some other forgotten cases: the ADDIN field
isn't the only one allowing a / or . in the field code. The proposed patch is a
much more generic fix!
Comment 55 michael.ruess 2009-09-01 16:02:35 UTC
cedricbosdo: I have closed this issue, because the problem stated by the
original attachment has been fixed and does still work in OOo 3.x. It may be
true, that your proposed patch fixes the problem in  a more generic manner, but
it is generally no good issue handling to reopen already fixed problems.
Meanwhile this issue became extremely inconvenient to read and handle due to the
high number of given comments.
Please file a new issue with "Issue type: Patch" and attach you patch proposal
and sample doc there, it will be handled much quicker than.