Issue 61224 - Incorrect placement of glyphs in complex text in print view
Summary: Incorrect placement of glyphs in complex text in print view
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.0
Hardware: All Unix, all
: P3 Trivial (vote)
Target Milestone: OOo 2.2
Assignee: stefan.baltzer
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks: 72107
  Show dependency tree
 
Reported: 2006-01-27 07:12 UTC by lists
Modified: 2007-09-19 14:50 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bugdoc (7.42 KB, application/vnd.oasis.opendocument.text)
2006-04-05 01:58 UTC, lists
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lists 2006-01-27 07:12:58 UTC
Placement of specific glyphs in Khmer is incorrect in print view of Writer, but
correct in Web view.

The problem affects certain superscript and subscript characters in fonts that
use marks.

The defect is incorrect horizontal placement of superscript and subscript
glyphs. It seems as if instead of advancing to the next cluster, horizontal
position is moved back to a position before (to the left of) the positoin of the
cluster that is being processed.

The fact that web view is correct makes us think that the problem is not in ICU. 

I wonder if it could be related to Issue 42975, which in theory had been fixed
in 2005 by the modification of the way in which OOo interprets the input from
ICU (By Herbert and Dan Williams) in gslpatches2 (I don't find the issue number).

I am attaching two views (print view and web view), each one of them with two
lines that represent 

1) Line above in the examples. The subscript is placed to the left of the
consonant (when it should be below), and any text that follows it is placed with
respect to the subscript, and therefore conflicts with the consonant that was
supposed to be above the subscript.

2) Line below. A problem with superscript in a slipt vowel (one part before the
consonant and another one above), in which the second part of the split vowel
(the one that goes above) is placed before the whole cluster, by itself, and the
rest of the cluster is sent to the right, almost as a separate cluster.



Both problems (probably the same), seem (to us) to be related to the handling of
marks.

Incorrect view (print view): 

http://www.khmeros.info/ooo/issues/printview.png

Correct:

http://www.khmeros.info/ooo/issues/webview.png
Comment 1 philipp.lohmann 2006-01-27 09:47:02 UTC
pl->hdu: please have a look
Comment 2 hdu@apache.org 2006-01-27 15:10:03 UTC
Yes, the problem isn't in ICU but in the "adjust layout for one device to
another device" routine. The glyph cluster boundaries are essential for this
task and issue 39982 changed them somewhat (it has been integrated in
SRC680m75). Was it ok in the beta?
Comment 3 lists 2006-01-28 02:17:18 UTC
I don't know. I don't have the beta (was it m84?). Do you know where i can find
it? I will test it.

Comment 4 hdu@apache.org 2006-03-14 15:40:56 UTC
setting a realistic target
Comment 5 lists 2006-03-15 12:25:01 UTC
Herbert,

Targeting this to 3.0 would be a huge blow for us. We cannot distribute
OpenOffice in Khmer if it does not render the script correctly, and we cannot
distribute Linux without OpenOffice. The whole migration plan of the Cambodian
Government would just collapse.

We tend to think that the problem is more with the managment of anchors that
with cluster recognition, because the text is displaced to the left while in the
middle of a cluster, and not to the right, as in the case of moving to a new
cluster. Fonts that do not use anchors do not seem to have this problem. It is
at the moment in which anchor calculations should take place (vertically) that
the displacement to the left happens.

We use fonts that use anchors for vertical placement of characters, as in some
cases the above signs need to be moved up because there is another sign on the
way, or the below vowels need to be moved down because there are subjoined
consonants (1 or 2).

Comment 6 hdu@apache.org 2006-03-17 13:03:25 UTC
Please provide a bugdoc matching to your screenshots and specify where to get
the font that has the problem. Maybe this issue was already accidentially fixed
by e.g. issue 62919.
Comment 7 lists 2006-04-05 01:56:49 UTC
Please find attached bugdoc.

Support for Khmer has improved in 2.0.2 final, some of the problems have
dissapeared, such as the first problem in the bugdoc. 

The second issue is still present.

The fonts necessary to reproduce the issue are:

 	KhmerOSmuol.ttf
  	KhmerOSsys.ttf

and they can be found in:

http://sourceforge.net/project/showfiles.php?group_id=133361&package_id=163973
Comment 8 lists 2006-04-05 01:58:07 UTC
Created attachment 35500 [details]
Bugdoc
Comment 9 hdu@apache.org 2006-06-27 14:49:11 UTC
Found it: when the layout result contains interleaved glyph cluster (e.g.
pLogClusters[]={1,1,2,1} for the second line in the bugdoc) then the adjustment
should be started at the leftmost glyph of each cluster.
Comment 10 lists 2006-06-27 15:05:08 UTC
Yiiiiipi !!!!

Thanks Herbert !  This was the last major problem for distributing Linux in Khmer.
Comment 11 ooo 2006-08-11 18:34:10 UTC
Retargeting to 2.1
Comment 12 karl.hong 2006-10-18 02:08:10 UTC
ready for QA.
Comment 13 ooo 2006-10-24 11:28:47 UTC
'mh' decided to postpone integration of CWS 'icuupgrade' to OOo2.2, aligning target.
Comment 14 stefan.baltzer 2006-10-25 12:17:38 UTC
SBA: Please note that this CWS will pass the QA tests soon and will be
integrated in the soon-to-come (next week, I heard) source tree for OOo 2.2.
It is "common" that Linux distributors use a version that is not exactly the
QA-blessesd release (or "stable version") in favor for their "personal" favorite
fixes and features. So there will be a way to distribute a Khmer Linux with an
integrated OpenOffice.org version that does include this fix without having to
wait for the release of OOo 2.2.
Comment 15 stefan.baltzer 2006-10-25 13:51:16 UTC
SBA: Verified in CWS isuupgrade.
Comment 16 lists 2006-10-26 15:30:48 UTC
We have been testing the patch and rendering works correctly for Khmer. The
problem is solved and we do not see any negative side-effects.

SBA: Thanks. We will submit it to the distributions we work with, for 2.1
Comment 17 stefan.baltzer 2007-09-19 14:50:21 UTC
SBA: OK in OOG680_m2 (OOo 2.3).
Closed.