Issue 61272 - Loop when moving object (inside frame) across page border
Summary: Loop when moving object (inside frame) across page border
Status: CLOSED DUPLICATE of issue 81146
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-01-28 18:16 UTC by psybases
Modified: 2013-08-07 14:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Buggy odt (99.87 KB, application/vnd.oasis.opendocument.text)
2006-01-28 18:18 UTC, psybases
no flags Details
simplified document to reproduce the layout loop (7.68 KB, application/vnd.oasis.opendocument.text)
2006-04-28 12:12 UTC, Oliver-Rainer Wittmann
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description psybases 2006-01-28 18:16:29 UTC
-Load the attachment in OO. 
- In page 6 there are some diagrams and some small orange tables. Try to 
change the position of the bottom-left diagram. 
- OO will hang and will consume near 100% CPU for ever.
Comment 1 psybases 2006-01-28 18:18:57 UTC
Created attachment 33644 [details]
Buggy odt
Comment 2 Joost Andrae 2006-01-29 12:15:53 UTC
JA: I tried this in OOo-Dev src680m153 wntmsci10.pro and I wasn't able to
reproduce this behavior. Maybe there was a problem within the 2.0.1 build which
has been fixed within the most recent (src680m153) build or it's platform related
JA->MRU: please have a look at this document within a Linux build
Comment 3 ace_dent 2006-01-29 18:24:12 UTC
Tested using OOo 2.0 & 680m152, WinXP SP2.

Could not reproduce.
->'psybases', does this always oocur on your system? Is there any further info
you can supply?

Regards,
Andrew
Comment 4 psybases 2006-01-29 19:00:03 UTC
Could you please test this on a Linux system? 
Could you also tell me how to see what is the milestone version of my build? 
 
Extra info: 
The specific build of Oo is 2.0.1 and is provided by Novell (SUSE Linux 10.0). 
The timestamp of the rpms is "17 Jan 2006". I am using the Greek (el) version 
of OO. 
 
Comment 5 michael.ruess 2006-01-30 10:50:25 UTC
It is not so easy to get the Loop as it sounds at first glance. I was only able
to reproduce it in two steps (tested on Linux and Windows)
Scroll to page 6 and move the bottom left frame there towards the end of the
page. Now when trying to move it again across the end of the page Writer will
freeze.
I think, what this makes the situation a little special is the fact, that the
objects on page sixe are all posiiotned in one large frame. It looks, that it
makes a problem to extend this surrounding frame over the page border.
Comment 6 Oliver-Rainer Wittmann 2006-04-28 12:12:52 UTC
Created attachment 36133 [details]
simplified document to reproduce the layout loop
Comment 7 Oliver-Rainer Wittmann 2006-05-15 08:54:07 UTC
re-target to OOo 2.x, because OOo 2.0.3 deadline missed.
Comment 8 Oliver-Rainer Wittmann 2007-11-07 10:50:11 UTC
No longer reproducible in SRC680m236.
Comment 9 Oliver-Rainer Wittmann 2007-11-07 10:50:41 UTC
OD->MRU: Please verify and close this issue
Comment 10 michael.ruess 2007-11-08 11:22:45 UTC
Reopened to mark as duplicate.
Comment 11 michael.ruess 2007-11-08 11:23:34 UTC
Has been fixed by the implementation of th loopcontrol in issue 81146.

*** This issue has been marked as a duplicate of 81146 ***
Comment 12 michael.ruess 2007-11-08 11:25:14 UTC
Closed, will not loop anymore in OO 2.4.