Issue 61667 - Easter eggs present in non-beta
Summary: Easter eggs present in non-beta
Status: CLOSED WONT_FIX
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: Mac All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-06 13:06 UTC by lars.nooden
Modified: 2006-02-06 17:14 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lars.nooden 2006-02-06 13:06:12 UTC
There are at least two easter eggs in the release version of OOo 2.0
They are activated by the following:

=Game("StarWars") 

=Game(A1:C3;"TicTacToe") 

Easter eggs are fun, but not in the release versions.  In the interest of making
the install size smaller and reducing the number of parts (of which one could
contain an error) it would be best to remove all easter eggs from release
versions of OOo.
Comment 1 pavel 2006-02-06 13:40:51 UTC
Sorry, but no.
Comment 2 pavel 2006-02-06 13:41:50 UTC
Closing.
Comment 3 pavel 2006-02-06 13:43:01 UTC
We can't remove code from already released versions.

We don't plan to remove code from yet-to-be-released versions.
Comment 4 lars.nooden 2006-02-06 13:55:09 UTC
pjanik, please don't be so flippant.  OOo is used in schools and in work places.
 In addition to the concern stated above about the size of the code base and the
violation of the KISS-principle, you have the problem of the 'eggs themselves. 
Ian has pointed out
	http://marketing.openoffice.org/servlets/ReadMsg?list=dev&msgNo=22474
one very probable scenario:

 	"I can just imagine a teacher in a class
	being Inspected By OFSTED when some wag 
	finds the Easter Egg and suddenly all the 
	kids are playing space invaders instead of 
	doing their work. (failed lesson and in 
	the UK 15-20 failed lessons over a week can
	trigger special measures with the head losing 
	his job) A disaster like that would quickly 
	get round the grapevine and it would be another
	reason not to install OOo."

Just because MSO has easter eggs, doesn't mean  that it's good for OOo.


	"We can't remove code from already released versions."

Fine.

	"We don't plan to remove code from yet-to-be-released versions."

You mean 'not yet'.  There should be at least a discussion and solid basis for
the decision.
Comment 5 lars.nooden 2006-02-06 13:56:33 UTC
Making it possible for an admin to block all Easter Eggs would be a quick fix.
Comment 6 pavel 2006-02-06 14:02:24 UTC
duplicate.


*** This issue has been marked as a duplicate of 54703 ***
Comment 7 pavel 2006-02-06 14:02:46 UTC
Closing duplicate.
Comment 8 lars.nooden 2006-02-06 14:13:53 UTC
pjanik, I have looked at 54703 and it is related to 61667 but not a duplicate.
54703 is a query about the nature of the eggs. 

61667 is a specific request for either one of these:

 1) the removal of the eggs from future version

or 

 2) the ability for a system admnistrator to disable eggs
Comment 9 pavel 2006-02-06 14:19:09 UTC
I already answered 1.

> 2) the ability for a system admnistrator to disable eggs

System administrator can always disable any functionality because he has the
source code. We do not plan to provide tools for it. We would like to
concentrate on real stuff.

Please do not reopen already closed issues. Also you are changing the meaning of
the issue. File new one for new requests.
Comment 10 pavel 2006-02-06 14:19:37 UTC
Closing.
Comment 11 Olaf Felka 2006-02-06 14:32:56 UTC
Is there a chance to vote against this issue?
Comment 12 ace_dent 2006-02-06 17:14:19 UTC
To follow the eggciting (sic) debate, go to Issue 61685.

Regards,
Andrew