Issue 61720 - Ddate format in input pane should be in accordance to format in cell
Summary: Ddate format in input pane should be in accordance to format in cell
Status: CLOSED DUPLICATE of issue 5556
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: All Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-02-07 04:49 UTC by mausmon
Modified: 2006-03-07 13:23 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A partial screen capture showing the wrong date formats (8.93 KB, image/png)
2006-02-07 04:51 UTC, mausmon
no flags Details
A copy of my Tools/Options/Languages config page (31.76 KB, image/png)
2006-02-07 14:14 UTC, mausmon
no flags Details
A copy of my WinXP language configuration (55.61 KB, image/png)
2006-02-07 14:14 UTC, mausmon
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mausmon 2006-02-07 04:49:52 UTC
When entering a date, I prefer to enter (and display) ISO-8601 format, since it
is rather unambiguous.  I am fine with using cell formatting to display the date
as I want in the cells.  However, in the edit field, the date is displaying in a
different format.  There is no explicit place to set this that I can find.  This
format does not match the format of my operating system (which is ISO-8601 for
the format and Windows XP Home w/ latest patches for the OS).
Comment 1 mausmon 2006-02-07 04:51:23 UTC
Created attachment 33900 [details]
A partial screen capture showing the wrong date formats
Comment 2 Rainer Bielefeld 2006-02-07 06:37:01 UTC
I checked with "2.0.1 RC5 German version WIN XP: [680m1(Build8990)]" and can
confirm, that only the setting in Menu 'Tools - Options - Language settings -
Languages - locale setting' assigns the date format in the input pane. Your
problem is solved by setting the selection to "Swedish", but I do not know
whether that might cause other problems. So an option "Use format from cell for
input pane" might be useful.
Comment 3 mausmon 2006-02-07 14:14:08 UTC
Created attachment 33912 [details]
A copy of my Tools/Options/Languages config page
Comment 4 mausmon 2006-02-07 14:14:58 UTC
Created attachment 33913 [details]
A copy of my WinXP language configuration
Comment 5 mausmon 2006-02-07 14:20:10 UTC
I just attached copies of my language configuration for both OOo and WinXP. 
Notice on the WinXP configuration that the short date format is indeed
YYYY-MM-DD.  The default format for Canada is MM-DD-YYYY or DD-MM-YYYY (I can
never remember, thus why I prefer ISO-8601 format).  I'm guessing that it's
checking which country I'm using and using its date format instead of checking
what date format I've specified.

A configuration option could be added to use the format from the cell, as you
say.  Another fix could be to make it use the current user's date setting (which
may be overridden) instead of the  date setting for the current user's locale.

Thanks for looking into this!
Comment 6 frank 2006-03-07 13:22:43 UTC
Hi,

this is a double to Issue 5556 .

Frank

*** This issue has been marked as a duplicate of 5556 ***
Comment 7 frank 2006-03-07 13:23:23 UTC
closed double