Issue 61724 - Runtime Error while opening a document in a win98 network via Windows Explorer
Summary: Runtime Error while opening a document in a win98 network via Windows Explorer
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.1
Hardware: PC Windows XP
: P3 Trivial with 8 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
: 59684 60329 62178 (view as issue list)
Depends on:
Reported: 2006-02-07 09:17 UTC by ranki
Modified: 2017-05-20 10:45 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description ranki 2006-02-07 09:17:06 UTC
I have a WinXP machine with OOo 2.0.1 installed. The PC is connected to a win98

I open a document (doesn't matter, if word-doc or oo-doc) within the network via
the windows explorer. The following error message is displayed and the doc is
not opened:
Runtime Error!
Program: "c:progr....soffice.bin"

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

I can open the document via Windows Explorer, if it is stored locally. Neither
connecting the network folder as a local drive nor a reinstallation does help.

I can only open this document via the open-doc-dialog from OO, as it is working,
but I think it is not satisfactorily.

If you need further details do not hesitate to contact me!

Best regards,
Sascha Rankers
Sascha Rankers
.:skype sascha.rankers
.:icq 72946954 

WinXP Maschine mit Open Office Version 2.0.1 installiert. Windows Netzwerk mit
98 SE Rechnern.

Wenn ich nun versuche über den Windows Eplorer eine oo-Datei zu öffnen bekomme
ich nur eine Runtime FM:

Runtime Error!
Program: "c:progr....soffice.bin"

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Wenn ich nun oo seperat öffne und über den Öffnen Dialog die Datei auswähle
funktioniert es einwandfrei. Es funktioniert auch einwandfrei, wenn ich im
Explorer eine oo-Datei lokal öffne (also auf einem lokalen Datenträger).

Versuche ich den Netzordner als Laufwerk zu mappen bekomme ich den selben Fehler.

Ich finde über Runtime Fehler einiges Google (und dieses Forum), aber nichts

Eine Neuinstallation hat leider auch nichts gebracht. 
Comment 1 michael.ruess 2006-02-07 09:25:02 UTC
Framework issue.
Comment 2 edeku 2006-02-07 09:53:31 UTC
I can agree to the problem.
The other way: opening a OOo-document with OOo installed on a Win98SE-machine by
doubleklicking via windows-explorer on a network-resource XP-machine works as
desired by mapped networkresource and by UNC-path.
Comment 3 lars 2006-02-09 15:11:41 UTC
probably duplicate to issue 60329
Comment 4 rails_nut 2006-02-18 12:30:23 UTC
Plenty of other people getting this error, myself included. See .

Contact me for additonal info if required. My set up is basically WinXp SP2 with
new install of OOo 2.0.1 trying to launch network files (using double-click)
hosted by  Win98 machine. 
Comment 5 rails_nut 2006-02-18 12:31:23 UTC
*** Issue 61724 has been confirmed by votes. ***
Comment 6 hwoarang 2006-02-25 12:45:41 UTC
*** Issue 62178 has been marked as a duplicate of this issue. ***
Comment 7 hwoarang 2006-02-25 12:46:20 UTC
adding aswebdesign to CC.
Comment 8 hwoarang 2006-02-25 12:48:31 UTC
*** Issue 60329 has been marked as a duplicate of this issue. ***
Comment 9 hwoarang 2006-02-25 12:53:07 UTC
This problem was covered by issue 51026 (that is fixed (?) now).

Comment 10 hwoarang 2006-02-25 12:54:16 UTC
*** Issue 59684 has been marked as a duplicate of this issue. ***
Comment 11 dbauckmeier 2006-02-25 13:20:56 UTC
Workaround for this issue:
Drag the file for opening from network folder (win 98 server) to an open firefox
window. Confirm the opening window. File will be opened with OO2.

Dieter Bauckmeier 
Comment 12 ranki 2006-02-28 11:12:40 UTC
Issue 51026 was closed with the following comment by andreschnabel:
"verified with OOo 2.0.1 final on win98 -> close"

But I cannot confirm, that is fixed as I started this issue with the above
mentioned system.

The workaround from rainerbielefeld:
"here is a workaround (at least for WIN networks) that solves the problem.
I did several successful tests after I established a "Net drive assembly" ((?)
from german: "Netzlaufwerk") on the WIN 98 PC, so we can reduce priority"
does also not work for me as I mentioned in my issue description.

The only workaround I found was the same defined in issue 59684 by hgnet.
"Another work-around is to place a shortcut pointing to
"C:\Programme\OpenOffice\program\soffice.exe -o" into the sendto folder!"

I created by myself also a batchfile for the "SendTo" menu and start a document
with this option.
Comment 13 hwoarang 2006-02-28 16:15:03 UTC
Using OOo dialogs is another workaround.

Comment 14 thorsten.martens 2006-03-29 05:53:31 UTC
TM-MAV: Please have a look, Thanks !
Comment 15 ranki 2006-05-22 20:27:41 UTC
sorry, but I would like to know, if there are any news on this issue?

Thanks a lot and best regards
Comment 16 mikhail.voytenko 2006-05-23 10:49:29 UTC
Changing the target.
Comment 17 mikhail.voytenko 2006-06-30 13:58:13 UTC
Can not reproduce the problem in our environment. I have tried to open documents
placed on Win98 machine using double-klick in Windows Explorer from two
different WinXP machines ( both are WinXP SP2, with the latest patches from MS )
and everything worked like a charm. So it should be an environment-dependent

In one of duplicate issues it was mentioned that the scenario works well on
WinXP SP1 machine. So the problem might be caused by SP2, and might be solved by
the latest patches. But it is only a guess.

It would be nice if somebody who owns an affected WinXP SP2 machine installed
all the latests patches and tried the scenario again.
Comment 18 mikhail.voytenko 2006-07-11 09:26:53 UTC
MAV->HRO: The problem seems to happen before the SVMain is called ( the debug
printing in this method seems not to be reached ). Could you please take a look.
Comment 19 mikhail.voytenko 2006-07-17 09:49:51 UTC
Sorry. It looks like I have introduced incompatibility in one of the libraries.
Taking the bug back for further investigation.
Comment 20 mikhail.voytenko 2006-08-01 12:33:30 UTC
Changing the target.
Comment 21 mickey69 2006-10-04 16:26:14 UTC
Hallo, I have some PC with OS Win NT/Win 2000 and OOo 2.0.3 installed, connected
to a Win NT 4.0 server (the network file server).
I can't open OOo-document using UNC path (in task manager I see soffice starting
and then crashing without error messages) from another application. The same
error double-clicking the file on Windows Explorer on a network resource.
If I map the network resource on a drive, it works.
Unfortunately I must use the UNC path, because of different environment
configuration on the PCs connected to the file server.
Error in OOo configuration or bug not resolved in 2.0.3 version?
Thank you in advance

Comment 22 atdsm 2006-12-06 16:16:16 UTC

What you are talking about seems to be a seperate issue. Please see issue 19287.
Comment 23 Mathias_Bauer 2007-12-04 16:19:15 UTC
according to release status meeting -> target 3.x
Comment 24 Marcus 2017-05-20 10:45:10 UTC
Reset the assignee to the default "".