Issue 61764 - function for packing dbase tables needed
Summary: function for packing dbase tables needed
Status: CLOSED DUPLICATE of issue 40784
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: dbaneedsconfirm
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-08 06:14 UTC by ms2
Modified: 2006-05-31 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ms2 2006-02-08 06:14:50 UTC
OO.o base is lacking the functionality for purging the records marked for
deletion in a DBase table. Currently these tables are growing all the time.

The name for this funtion should be "pack" (german "Reorganisieren").

Another related task is to rebuild the indexes with a "reindex" command.

Both of these should be available at the GUI (SO5.2 had it in the context menu
at the "tables" node in the DB browser) and via API for using programmatically.
Comment 1 marc.neumann 2006-02-08 07:10:20 UTC
Resolve issue, mark it as duplicate of issue 40784

*** This issue has been marked as a duplicate of 40784 ***
Comment 2 marc.neumann 2006-02-08 07:10:37 UTC
close